Results 1 to 13 of 13
  1. #1
    Anti-Bullshit PowerWheels's Avatar
    Join Date
    October 2003
    Location
    AL
    Posts
    5,521

    P2197, P0171, P0174 Codes

    Well, my cars engine light came on, here are the codes.

    P2197
    P0171
    P0174

    The car just started to idle high yesterday and also idles a bit rough. I have noticed a bit of power loss under WOT pulls in 3rd and 4th over the last week. Any assistance on the fix would be greatly appreciated.

    I did get a COP wet once and had to take the plug cover off and dry it. Other than that never had any electrical issues.

    Car has 92k on it, I just replaced the K&N Filter 2 days ago and the plugs were changed about 20k-30k ago as well as the fuel filter.

    I haven't cleaned the MAF in a long while. Edit: The rear O2 sensors are turned off in my tune.

    Mods are in the sig.
    Last edited by PowerWheels; 06-23-2009 at 09:17 PM.
    2014 GT500
    Airaid Synthetic Filter, Ford Resonator Delete, JLT Passenger Side Oil Separator, Yeager Bros Front Gravel Guards, FRPP L Springs, BMR Panhard, Michelin 275/295 Y105 Tire Combo, Driver Mod....

  2. #2
    Anti-Bullshit PowerWheels's Avatar
    Join Date
    October 2003
    Location
    AL
    Posts
    5,521
    Been researching, I'm going to clean the MAF and look for any obvious vacum leaks, where I have no idea, andy suggestions?

  3. #3
    SVT God TERMIN8TR's Avatar
    Join Date
    June 2004
    Location
    Here
    Posts
    5,347
    P2197-????
    P0171-System Too Lean (Bank 1)
    P0174-System Too Lean (Bank 2)

  4. #4
    Easy Going MFNG 03cobra#694's Avatar
    Join Date
    August 2008
    Location
    SW FL.
    Posts
    18,488
    DTC: p2197 Ford says the cause may be an engine vacuum leak, possibly around the PCV valve or in the PCV vacuum plumbing. Such a leak may set the following DTC: P2197. The code may indicate a lean fuel condition or a lack of heated oxygen sensor (HEGO) switching. Ford says not to replace the oxygen sensor, MAF sensor or PCM because the cause may only be a vacuum leak or an incorrect sized PCV valve that flows too much air.
    I`d look for a vacuum leak

  5. #5
    SVT God TERMIN8TR's Avatar
    Join Date
    June 2004
    Location
    Here
    Posts
    5,347
    Quote Originally Posted by 03cobra#694 View Post
    DTC: p2197 Ford says the cause may be an engine vacuum leak, possibly around the PCV valve or in the PCV vacuum plumbing. Such a leak may set the following DTC: P2197. The code may indicate a lean fuel condition or a lack of heated oxygen sensor (HEGO) switching. Ford says not to replace the oxygen sensor, MAF sensor or PCM because the cause may only be a vacuum leak or an incorrect sized PCV valve that flows too much air.
    I`d look for a vacuum leak
    Which would give the other 2 codes. Good catch, check for a vacuum leak

  6. #6
    Easy Going MFNG 03cobra#694's Avatar
    Join Date
    August 2008
    Location
    SW FL.
    Posts
    18,488
    Quote Originally Posted by TERMIN8TR View Post
    Which would give the other 2 codes. Good catch, check for a vacuum leak
    Exactly

  7. #7
    Anti-Bullshit PowerWheels's Avatar
    Join Date
    October 2003
    Location
    AL
    Posts
    5,521
    The PCV tube going from the valve cover to the intake is fine. What's next.

  8. #8
    SVT God
    Join Date
    July 2004
    Location
    texas
    Posts
    3,147
    Had the same code PO174:
    reset code ...never came back!

    Quote Originally Posted by PowerWheels View Post
    The PCV tube going from the valve cover to the intake is fine. What's next.
    03 Yellow Cobra
    2nd motor(now, with cooling mod)
    2.93/4lb Steg Stage 4
    I swear Honey.."Its just a scuba tank"

  9. #9
    Anti-Bullshit PowerWheels's Avatar
    Join Date
    October 2003
    Location
    AL
    Posts
    5,521
    I've reset it and it comes back, plus it's not running correctly. Going to clean the MAF tonight, i don't expect it to help, but it won't hurt.
    Last edited by PowerWheels; 06-24-2009 at 06:32 PM.

  10. #10
    Anti-Bullshit PowerWheels's Avatar
    Join Date
    October 2003
    Location
    AL
    Posts
    5,521
    Well cleaned the MAF and a few electrical plugs. Now I'm pissed, the plug that goes to the A/C broke. Off to Ford to buy another in the AM, I'm probably just going to let them look at it.

  11. #11
    Anti-Bullshit PowerWheels's Avatar
    Join Date
    October 2003
    Location
    AL
    Posts
    5,521
    Did take it to them, and you guys were right, a hose behind the S/C was letting air in. Wish I would have found it myself, but it's running great now.

  12. #12
    Easy Going MFNG 03cobra#694's Avatar
    Join Date
    August 2008
    Location
    SW FL.
    Posts
    18,488
    Quote Originally Posted by PowerWheels View Post
    Did take it to them, and you guys were right, a hose behind the S/C was letting air in. Wish I would have found it myself, but it's running great now.
    Glad you got it fixed

  13. #13
    Big Hitter da LLama! x NOODLES x's Avatar
    Join Date
    February 2005
    Location
    Spokane, WA
    Posts
    6,176
    Quote Originally Posted by 03yellow View Post
    Had the same code PO174:
    reset code ...never came back!
    +2
    She's Gone.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •