Results 1 to 8 of 8
  1. #1
    FNG Co-brat's Avatar
    Join Date
    January 2008
    Location
    Washington
    Posts
    2,530

    Emissions testing question

    How long does it take after you clear the trouble codes from the computer before the system is ready to test? I have a check engine light and my car is due for emissions and I know you cant just clear the code and just test it cause it will fail. So is a certain amount of milage or time or does anyone know? thanks for your input.

  2. #2
    SVT God Blueline's Avatar
    Join Date
    January 2011
    Location
    New Jersey
    Posts
    3,521
    It really depends, my car took 20 miles after I loaded the stock tune in for inspection. Other guys have driven hundreds of miles. Heres the procedure from Ford though. Hopefully it helps.

    Ford Motor Company Driving Cycle

    2003 DSG Cobra

  3. #3
    FNG Co-brat's Avatar
    Join Date
    January 2008
    Location
    Washington
    Posts
    2,530
    ^^^ damn thats quite a procedure^^^ Im pretty sure my tune is not the issue, I have a minor exhaust leak and the code that keeps popping up says something like "left bank lean condition"

  4. #4
    SVT God Blueline's Avatar
    Join Date
    January 2011
    Location
    New Jersey
    Posts
    3,521
    You may have an o2 sensor that went bad. I didnt mean your tune was bad. What I meant with the tune was that I had to re install my stock tune to pass emissions. My performance tune had everything turned off, so it read "not ready" or "unsupported." That obviously will not pass emissions. So I had to either have everything turned on in my tune, or download the stock tune. When I decided to download the stock tune, obviously my computer had to "relearn" everything and "ready" all of the parameters. FOr me it took 20 miles of driving to inspection station from my house to have everything ready. If you have a check engine light on, you have to fix the reason its on and then have your computer start over. Hope this helps

  5. #5
    FNG Co-brat's Avatar
    Join Date
    January 2008
    Location
    Washington
    Posts
    2,530
    Anyone else have any experiences with this??
    CURRENT SETUP:WHIPPLE 2.9L/ LETHAL PERFOMANCE BUDGET RETURN FUEL SYSTEM/ 60LB. INJECTORS/ SNOW PERFORMANCE STAGE 2 METHANOL INJECTION/ BLACK BILLETFLOW SBTB/ SCT BA3000 MAF/ JLT INTAKE/ SCT XCAL2/ BILLETFLOW IDLERS/ UPR OFF ROAD X PIPE/ STAINLESS CATBACK WITH FLOWMASTERS WELDED IN/ MMFLSFCs/ BILLETFLOW IRS BRACE/ SLOTTED ROTORS/ STAINLESS BRAIDED BRAKE LINES/ EBC REDSTUFF PADS/ EVEN FLOW GEN2 COOLING MOD/ H&R SPORT SPRINGS/ HURST SHIFTER/ FIORE FIREWALL ADJUSTER/ STEEDA CLUTCH QUADRANT/ TRUE FORGED SATIN BLACK BILLET HOOD VENTS/ 305-40-18 MICKEY THOMPSON ET STREETS/ CHROME 18" 10TH ANN. REPLICAS

    TUNED BY ERIC BROOKS OF BROOKSSPEED TUNING

    WISH LIST: FTBR IRS BUSHINGS/ STEEDA X2 BALLJOINTS/ MM STEERING RACK BUSHINGS/ AFCO HEAT EXCHANGER/ CCW CLASSICS/ NITTO NT05R DRs/ MAGNAFLOW OFFROAD X PIPE/ REAR SEAT DELETE/ 6PT. ROLLBAR/ HOT NAKED GIRL RIDING SHOTGUN FULL TIME

  6. #6
    Lake Bum earico's Avatar
    Join Date
    January 2011
    Location
    San Antonio
    Posts
    3,241
    Quote Originally Posted by Blueline View Post
    You may have an o2 sensor that went bad. I didnt mean your tune was bad. What I meant with the tune was that I had to re install my stock tune to pass emissions. My performance tune had everything turned off, so it read "not ready" or "unsupported." That obviously will not pass emissions. So I had to either have everything turned on in my tune, or download the stock tune. When I decided to download the stock tune, obviously my computer had to "relearn" everything and "ready" all of the parameters. FOr me it took 20 miles of driving to inspection station from my house to have everything ready. If you have a check engine light on, you have to fix the reason its on and then have your computer start over. Hope this helps
    I have the SCT 4bank chip in my car. I took it to inspection with it installed. Everything came up "unsupported" like you said. I just acted dumb. He then told me the car was chipped and would never fail inspection. I was like oh....thanks.

    Here in Vegas they just plug into the OBDII port and read the computer. He never popped the hood. My EGR is removed and etc.

    2010 e85 GT-R
    2008 CCSB F-250 6.4 King Ranch
    2003 S-Type Jag 4.2
    2003 Cobra Convertible - GONE

  7. #7
    Beat'em with a stick! Snake Plissken's Avatar
    Join Date
    February 2009
    Location
    St. Louis County, Missouri
    Posts
    765
    In MO. if the check light is on. your out'a luck, they won't even bother pluging into the OBDII port; it's hit the road jack and don't come back till.....
    My car comes-up "unsupported" too, but thanks to the politicians in MO. if you drive your car/truck less than 6,000 miles a year you don't have to be emission tested.
    Sorry I can't help..........G/L

  8. #8
    FNG Co-brat's Avatar
    Join Date
    January 2008
    Location
    Washington
    Posts
    2,530
    Yeah in Washington. If the CEL light is on its an automatic fail as well. I just know that you can't test the car immediately after the codes are cleared the car will not pass. It takes a certain distance or amount of time.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •