Results 1 to 20 of 20
  1. #1
    bad mamba jamba Eagle24's Avatar
    Join Date
    July 2006
    Location
    Clarksville TN
    Posts
    1,365

    Factory clutch hissing sound

    Just curious if anyone else has experienced a "Hissing" noise on the factory clutch when you begin to release? I'm pretty new to the GT500's, the car drives and shifts perfect, but the hiss only happens as you release the clutch.

  2. #2
    Unknown Cyborg 03 DSG Snake's Avatar
    Join Date
    November 2002
    Location
    CA
    Posts
    19,803
    Normal.

    2003 DSG Cobra Coupe
    2.3L Whipple, full MM suspension
    575 rwhp/499 rwtq
    2007 Tungsten Grey Shelby GT500 Coupe
    Eaton upper only car. HRE.
    545rwhp/530rwtq
    2013 Focus ST

  3. #3
    Rookie SVT Poster Islandcat's Avatar
    Join Date
    July 2009
    Location
    Grand Isle
    Posts
    97
    Quote Originally Posted by 03 DSG Snake View Post
    Normal.
    and awesome

  4. #4
    Engine Lubrication Guru UnleashedBeast's Avatar
    Premium Member
    Join Date
    October 2010
    Location
    Pensacola, Florida
    Posts
    8,442
    My friend said it was the Cobra ready to strike sound.
    2014 Mustang GT: Sterling Gray | NAV | Recaros | Brembos | Glass Roof | back up camera | 6 speed auto

    Armageddon Twin Turbo build thread

    2007+ Shelby GT500 UOA thread | 2012+ Boss 302 UOA Thread | 2011+ GT UOA Thread

  5. #5
    EpicProto Proto's Avatar
    Join Date
    May 2010
    Location
    NC
    Posts
    2,182
    07-09, happens on every one of them. Whenever u put an aftermarket clutch in, it goes away

    ____________________________________________
    i7-4770K @ 4.6ghz, 2x GTX 780 ti in SLI

    Steam, Origin, Uplay: EpicProto

  6. #6
    Rookie SVT Poster
    Join Date
    September 2011
    Location
    DFW
    Posts
    33
    mine does it when you turn the car off too!

  7. #7
    Insane SVT Poster pony23's Avatar
    Join Date
    August 2007
    Location
    Ct
    Posts
    1,165
    Thanks for the post. I have been wondering about that for the last year.
    "It's a shiney d**k with two chairs in it, and we're just the balls dragging along behind"--Bad Boys

  8. #8
    Crazy SVT Poster
    Join Date
    October 2011
    Location
    Spring, TX
    Posts
    221
    Quote Originally Posted by livnpaintball2 View Post
    mine does it when you turn the car off too!

    Haha, Mine too.
    2012 F250 4x4 Lariat ultimate diesel
    Volant CAI
    H&S tuned
    DPF and Cat delete
    5 inch Flopro stainless exhaust

    2012 Honda Odyssey (wife's car)

    2007 Rinker Captiva 242
    496 HO
    Corsa thru hull exhaust

  9. #9
    CTSV > GT500
    Join Date
    September 2004
    Location
    Louisiana
    Posts
    6,409
    It hasn't attacked you yet has it? From what I understand it's coiled and ready to strike.

    But yes, normal.
    13 CTS V coupe 12.10 @ 119.65
    12 GT500 12.06 @ 117.9, the one and only time it shifted into 2nd under power.
    13 Explorer Sport 13.44 @ 102.9
    06 GTO 12.95 @ 109.2
    99 Lightning 12.44 @ 108
    93 Lightning

  10. #10
    Crazy SVT Poster
    Join Date
    July 2007
    Location
    Texas
    Posts
    802
    That's the only thing I miss about the OEM clutch....or should I say clutches.

    Deposit in May of '05. Delivered November 1st. 2006.

  11. #11
    vertias y aequitas notfastenuf's Avatar
    Join Date
    March 2006
    Location
    Houston
    Posts
    1,664
    Quote Originally Posted by UnleashedBeast View Post
    My friend said it was the Cobra ready to strike sound.
    wtf :rofl:
    -Ty


  12. #12
    More Power! GT500RedStripe's Avatar
    Premium Member
    Join Date
    August 2010
    Location
    Darnestown, MD
    Posts
    4,699
    I miss my hisssssssss!

  13. #13
    S/C Whine = Smile on Face BlwnSn8k's Avatar
    Join Date
    June 2010
    Location
    Savannah, GA
    Posts
    97
    Quote Originally Posted by Proto View Post
    07-09, happens on every one of them. Whenever u put an aftermarket clutch in, it goes away
    My '10 makes the same sound; low rpm from a dead stop. Normal so far.

    Former Owner Of:
    Built 21 Dec. 2009
    #3353 of 3545 Coupes
    #358 of 384 in Performance White


    "There are four boxes to be used in defense of liberty: Soap, Ballot, Jury, and Ammo. Use in that order." -Ed Howdershelt

    "Light travels faster than stupidity. That's why some people seem cool until they open their mouth....."

  14. #14
    Insane SVT Poster rodfarva's Avatar
    Join Date
    March 2010
    Location
    Kentucky
    Posts
    1,125
    You're ok as long as it doesn't go "blap, blap, blap"
    8 sec 2010 GT500 with Whipple 4.0



    I see dumb people...they're everywhere. They walk around like everyone else. They don't even know that they are dumb.

    http://neverfastenoughracing.com

  15. #15
    OVERTHINKER torkum's Avatar
    Join Date
    March 2011
    Location
    Mt Juliet TN
    Posts
    12
    Just bought a 07 yesterday and heard the hiss when I pulled in the garage.

  16. #16
    bad mamba jamba Eagle24's Avatar
    Join Date
    July 2006
    Location
    Clarksville TN
    Posts
    1,365
    Hah thanks guys, I have a good friend that has an 08, he also said his factory clutch did the same thing. Good to know thanks guys!

  17. #17
    Engine Lubrication Guru UnleashedBeast's Avatar
    Premium Member
    Join Date
    October 2010
    Location
    Pensacola, Florida
    Posts
    8,442
    Quote Originally Posted by rodfarva View Post
    You're ok as long as it doesn't go "blap, blap, blap"


    That joke never gets old.

  18. #18
    Crazy SVT Poster
    Join Date
    October 2011
    Location
    Spring, TX
    Posts
    221
    Anyone really understand why this hiss exist?

    I had a C5 which sounded like a marble in a paint can when you would shut it down. LOL. Turns out it was very normal

    I had an 07 CTS-V that had the sound but it was far less noticable.

    Not I have a hissing Cobra, just curious why it occurs.

  19. #19
    New SVT Poster
    Join Date
    November 2011
    Location
    Chickamauga, GA
    Posts
    1
    Glad to hear this is normal. Bought mine a few weeks ago to replace my 08 GT and its boggled me ever since.

    I am also curious as to why this happens

  20. #20
    Authorized Vendor Steve@TF's Avatar
    Join Date
    February 2006
    Location
    Los Angeles
    Posts
    14,303
    yeah i was wondering the same thing lol. since i bought my car bone stock with only 837 miles on it i figured it was normal.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •