Results 1 to 3 of 3
  1. #1
    Vicious vicioustrick's Avatar
    Join Date
    March 2007
    Location
    Virginia
    Posts
    102

    Antifreeze making supercharger belt squeel?

    I bought a new supercharger belt when I changed my lower pulley . It's a gates belt and it squeels when the engine is cold on startup. It continues to squeel until it warms up. It slowly start to quiet down until it stops.
    I put an engine in my cobra out of my other cobra and it was fine in the other car so I know the pullies aren't bent or wobbling. Also the belt was fine w the new pulley until antifreeze blew all over the motor due to a big air pocket in the coolant system from the engine install (I have aftermarket overflow reservoirs so the pressure kept blowing antifreeze past the cap). The coolant got on the belt and its been sqeeling ever since when its cold.
    Has anyone had this problem? Would buying a new belt help? I'm trying to put it in a show this weekend and don't want it sounding like a piece of shit hood rat car..lol
    Thanks
    Sonic Blue 03 Cobra - 2.9l Whipple, Accufab TB, 60lb inhectors, Fore return style fuel system w twin 255s, SCT 3000 MAF, bbk longtubes, bbk Cai, o/r xpipe, Borla Stinger catback, SCT tuned, chrome staggered 18" FR500's

  2. #2
    Moderator rich5150's Avatar
    Join Date
    August 2005
    Location
    Pittsburgh, Pa
    Posts
    1,325
    Quote Originally Posted by vicioustrick View Post
    I bought a new supercharger belt when I changed my lower pulley . It's a gates belt and it squeels when the engine is cold on startup. It continues to squeel until it warms up. It slowly start to quiet down until it stops.
    I put an engine in my cobra out of my other cobra and it was fine in the other car so I know the pullies aren't bent or wobbling. Also the belt was fine w the new pulley until antifreeze blew all over the motor due to a big air pocket in the coolant system from the engine install (I have aftermarket overflow reservoirs so the pressure kept blowing antifreeze past the cap). The coolant got on the belt and its been sqeeling ever since when its cold.
    Has anyone had this problem? Would buying a new belt help? I'm trying to put it in a show this weekend and don't want it sounding like a piece of shit hood rat car..lol
    Thanks
    Coolant is the squeak-king when it gets onto a belt. The quick test is to pour some water on the belt as its turning(the inside where the ribs are) you'll notice the squeak go away instantly.

    Completely remove the belt, get a new one. Clean all pullies with ribs with brake clean.

    You'll be good to go.

    2013 Mustang GT

  3. #3
    Vicious vicioustrick's Avatar
    Join Date
    March 2007
    Location
    Virginia
    Posts
    102
    That's awesome! Thanks bud. I'll see what happens. I figured it was the antifreeze but didnt know if i could just replace the belt and make it stop. ill clean the pullies now too! thanks again

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •