• Welcome to SVT Performance, your home for all things SVT

Ambient lighting magic

Discussion in 'SVT Shelby GT500' started by psycholx, Jul 24, 2012.

  1. psycholx

    psycholx ALWAYS STANG, SOMETIMES L Established Member

    Messages:
    313
    Joined:
    Dec 3, 2006
    Location:
    JBLM, WA
    I noticed my abient lighting going off when i put hte car in reverse. Is it suppost to do that? I seen it and I almost freaked, thought i was having electrical problems, everybody knows electrical problems are the worste. Just wondering have anyone else noticed this.
     
  2. DaFreak

    DaFreak New Member Established Member

    Messages:
    991
    Joined:
    Feb 18, 2010
    Location:
    Oregon
    Not here
     
  3. psycholx

    psycholx ALWAYS STANG, SOMETIMES L Established Member

    Messages:
    313
    Joined:
    Dec 3, 2006
    Location:
    JBLM, WA
    No one else checked?
     
  4. Blu50Stang

    Blu50Stang Happiness is being blown Established Member

    Messages:
    744
    Joined:
    Aug 1, 2003
    Location:
    Not CA
    Mine does not.
     
  5. YellowDreamSVT

    YellowDreamSVT New Member Established Member

    Messages:
    91
    Joined:
    Jul 17, 2007
    Location:
    Pennsylvania
    Mine doesn't either.
     
  6. Baby Gorilla

    Baby Gorilla MACA Member #531 Established Member

    Messages:
    572
    Joined:
    Mar 19, 2009
    Location:
    Northern Virginia
    Me neither.
     
  7. GLASSTOPGT500

    GLASSTOPGT500 New Member Established Member

    Messages:
    196
    Joined:
    Feb 10, 2012
    Location:
    Far away
    Hey did u end up figuring out whats going on with the lighting?? 2012 shelby with electrical mysteries, can't say I ever seen it before. MAYBE there is a fuse that blew and caused something to rest in an open circuit when the tail lights go on or something? I really hope it isn't an electrical problem, I would want a new car!
     
  8. 54First

    54First Grouchy Old Guy Established Member

    Messages:
    562
    Joined:
    Aug 29, 2010
    Location:
    Central Valley, CA
    On my 2008 the ambient control switch is on the right side of the console. If the 2012 is the same, the ambient wire harness runs past the shifter on the right hand side and would be closest to the lever in reverse. Check for some kind of interference, either a short or the harness pulling on the switch, etc. If the switch is somewhere else, I have no clue.

    Steve
     
  9. psycholx

    psycholx ALWAYS STANG, SOMETIMES L Established Member

    Messages:
    313
    Joined:
    Dec 3, 2006
    Location:
    JBLM, WA
    Steve, no switch in the consol that I am aware of. controls are on the lower left dask.


    Glasstop, I did figure it out, 1400 dollars later. It was the PCM dropping the crank sensor. They replace crank and cam sensor, thought it was fixed, and it did it again when they went to pull the truck out the garage, more testing revealed the PCM, got a new one, all was good, then had a EVAP sensor bad, replaced, no issues. Running great now, just 6 miles from 40000 miles.

    As far as the ambient lighting, i did a little testing today, when in reverse it goes out and flashes maybe every two seconds, put it back in neutral, it comes back on. So I tried it with the car running vs not running. It only does it when the car is running. If I turn the car off, it comes back on. If I turn on the ignition and not start it stays on, but once the car is started, it goes out and blinks like stated above. Maybe its an alert feature that tells you the car is in reverse when its dark out and inside the car. I dont know, its not an a problem (yet), just want to know if its normal or if something is wrong. Thanks for all the replies, I ask all the Shelby owners check to see if theirs does it, 2012 year.

    Thanks again.
     
    Last edited: Jul 26, 2012
  10. psycholx

    psycholx ALWAYS STANG, SOMETIMES L Established Member

    Messages:
    313
    Joined:
    Dec 3, 2006
    Location:
    JBLM, WA
    After reading thru this thread, I realized that I mixed up an issue with my Lightning and the Shelby. Glasstop, I apologize for giving you the wrong information. i did get the light issue fixed, dealearship said it was the BCM module,, they replaced, still no fix. After further investigation, they finally removed the panel behind the lights and noticed the reverse light wire was pinched behind the mounting stud and bolt, shorting against the body. They spliced wire, retightened the nut, and all is good now. My first thought from the beginning was to looked behind the panel, but I said to myself, "Self, its under warranty, take it to the dealership."
    The guy that switched the lights when I traded the '10 GT in must have pinched it when he changed it. Anyway, all is good.
     
  11. NuclearPower

    NuclearPower New Member Established Member

    Messages:
    522
    Joined:
    Aug 12, 2011
    Location:
    Texas
    2012 here and the ambient lighting stay on the entire time. It does NOT go off when in reverse.
     
  12. GLASSTOPGT500

    GLASSTOPGT500 New Member Established Member

    Messages:
    196
    Joined:
    Feb 10, 2012
    Location:
    Far away
    lol yeah I did get what you meant... figured "lighting/lightning" made you think of the other issue
    Sounded something like that, I used to be a mobile electronics installer as one of my first real jobs, its one of the nightmares you don't want to deal with. Good thing it was not a wire that could have messed up alot more then just the ambient lighting. Once when I was young and stupid, on my first Mustang I hooked up my aftermarket tach to the "park lighting" ... well one day driving it all I guess melted and shorted and I needed to get my ignition coil and some other wiring replaced. :) not as lucky as a ambient lighting wire. Did not help that it was freezing cold that night and I had shit all to work with to get it running again... tow truck $150... mechanic $400... knowing what the heck you are doing... $priceless
     
    Last edited: Sep 6, 2012
  13. psycholx

    psycholx ALWAYS STANG, SOMETIMES L Established Member

    Messages:
    313
    Joined:
    Dec 3, 2006
    Location:
    JBLM, WA
    Fixed!
     

Share This Page