• Welcome to SVTPerformance!

2015 mustang gt auto with procharger tune issue

Discussion in '5.0L Coyote V8 Engine Modification/Discussion' started by Niko, Dec 5, 2016.

  1. Niko

    Niko New Member

    Messages:
    4
    Joined:
    Dec 5, 2016
    Just installed the procharger ho kit with procharger tune on 15mustang with auto trans. Since the tune the car has driven like crap. And when its warmed up, if i try to revv it up and let off the gas the rpms hang. They hang until i shut the engine off. Does anyone have any ideas?
     
  2. crfrider16

    crfrider16 Heretic Established Member

    Messages:
    827
    Joined:
    Mar 12, 2010
    Location:
    Flemington, NJ
    Can only be 2 things. Hardware/installation issue, or tune. Double check your install, vacuum leaks, etc. Then it's time to hire a real tuner to check logs and see what's really happening.

    Sent from my SAMSUNG-SM-G930A using Tapatalk
     
  3. Niko

    Niko New Member

    Messages:
    4
    Joined:
    Dec 5, 2016
    Thanks so much, ive triple checked my hardware. I will see about a tune
     
  4. Zemedici

    Zemedici Well-Known Member Established Member

    Messages:
    19,565
    Joined:
    Jan 7, 2013
    Location:
    Atlanta, GA
    Where are you located?
     
  5. Niko

    Niko New Member

    Messages:
    4
    Joined:
    Dec 5, 2016
    Im in Camarillo Ca
     
  6. Zemedici

    Zemedici Well-Known Member Established Member

    Messages:
    19,565
    Joined:
    Jan 7, 2013
    Location:
    Atlanta, GA
    damn, thought you were out this way (east coast)

    Best suggestion is to post in the california section and have some locals name off a few spots
     
  7. Niko

    Niko New Member

    Messages:
    4
    Joined:
    Dec 5, 2016
     

Share This Page