• Welcome to SVTPerformance!

03/04 Cobra Gauge cluster illuminance fixed HERE!!!

Discussion in 'Vendor’s Specials' started by CobradaCableGuy, Sep 6, 2009.

  1. mmustangsrus

    mmustangsrus boost makes daddy happy Established Member

    Messages:
    4,069
    Joined:
    Oct 10, 2005
    Location:
    NASHVILLE, TN
    i got a extra cluster laying around you interested in it
     
  2. CobradaCableGuy

    CobradaCableGuy New Member Established Member

    Messages:
    335
    Joined:
    May 9, 2009
    Location:
    Texas
    Pm'ed you...
     
  3. Grewe02

    Grewe02 New Member

    Messages:
    1
    Joined:
    Aug 26, 2012
    Location:
    San Diego
    I tested my lights with 12v straight to the gauges, after the inverter. Everything worked. So then read the input voltage from the cluster to the inverter, 9.3v. Any idea if this is correct or not?
     
  4. CobradaCableGuy

    CobradaCableGuy New Member Established Member

    Messages:
    335
    Joined:
    May 9, 2009
    Location:
    Texas
    Please send it in for service, there is no way possible that I can know what's going on with the cluster over the forum, I would need to look/ service it. If you supply direct current to the cluster you will burn the insert, that is for sure and possibly start an electrical fire. Please be carful what you do guys, be safe!!!:beer:
    Contact me if you need service for your cluster via PM !!!
     
  5. CobradaCableGuy

    CobradaCableGuy New Member Established Member

    Messages:
    335
    Joined:
    May 9, 2009
    Location:
    Texas
    Still going.... Hope you all have a safe 2013
     
  6. ti-force

    ti-force Member Established Member

    Messages:
    97
    Joined:
    Jun 12, 2007
    Location:
    Georgia, U.S.
    Are you still restoring illuminessence for these clusters? After the repair is made, is the illuminessence still voltage regulated so as not to be affected by small voltage changes? I installed some electro luminescent gauge faces and auto meter c2 gauges years ago and they were not voltage regulated and would not maintain a constant brightness at idle. The one I installed in my cluster had the option of being switched between blue and green via an external switch. What actually fails in these clusters?
     
  7. knightrida5

    knightrida5 Member Established Member

    Messages:
    54
    Joined:
    Jan 27, 2009
    Location:
    DFW
    Still active? Cluster not lighting any solutions?
     
  8. ti-force

    ti-force Member Established Member

    Messages:
    97
    Joined:
    Jun 12, 2007
    Location:
    Georgia, U.S.
    He never replied to my post back in 14' so it doesn't look like he is. From what I gather, aftermarket indiglo gauges are installed behind our 03 04 face to make the repair. Since there's not much detail on this thread I'm not sure if he wired the aftermarket gauges in to the factory cluster so that they dim with the cobra dimmer or if it has to be done externally. I did gather that the color change would be made by an external switch (probably the switch included with the indiglo gauge face). If you have some mechanical and electrical ability I'm sure you could do it yourself. That's what I will do when the need arises. http://m.uprproducts.com/mustang-gt-el-glow-gauges-96.html
     
  9. ti-force

    ti-force Member Established Member

    Messages:
    97
    Joined:
    Jun 12, 2007
    Location:
    Georgia, U.S.
  10. masonic sn95

    masonic sn95 New Member

    Messages:
    4
    Joined:
    Sep 18, 2013
    Location:
    toronto ontario canada
    I see where you're going with this..lol

    Sent from my [device_name] using the svtperformance.com mobile app
     

Share This Page