• Welcome to SVTPerformance!

1997 mustang cobra problem please help

Discussion in 'SN95 Cobras' started by Phillip Scocca, Aug 7, 2019.

  1. Phillip Scocca

    Phillip Scocca Member Established Member

    Messages:
    32
    Joined:
    Aug 4, 2019
    Location:
    Long Island
    1997 mustang cobra 65k miles runs and starts fine runs on all 8 cylinders the put if nowhere it only runs on like 4 cylinder me or so

    I have replaced the New plugs, plug wires, coil packs, connectors to coils please help

    Thank you
     
  2. Blown_By_You

    Blown_By_You Richard Head Established Member

    Messages:
    7,580
    Joined:
    Sep 22, 2005
    Location:
    Montana
  3. Makobra

    Makobra Well-Known Member Established Member

    Messages:
    373
    Joined:
    Nov 17, 2018
    Location:
    Texas
  4. musclemustang20

    musclemustang20 Member Established Member

    Messages:
    73
    Joined:
    Jul 19, 2004
    Location:
    los angeles
    Use a OB2 scan tool and look for codes.
     
  5. Phillip Scocca

    Phillip Scocca Member Established Member

    Messages:
    32
    Joined:
    Aug 4, 2019
    Location:
    Long Island
    Nothin comes up when we scan it
     
  6. Phillip Scocca

    Phillip Scocca Member Established Member

    Messages:
    32
    Joined:
    Aug 4, 2019
    Location:
    Long Island
    If you’re so smart from being on hooked on phonics as a young kid to an adult u would know what’s wrong with the car smart guy
     
  7. Makobra

    Makobra Well-Known Member Established Member

    Messages:
    373
    Joined:
    Nov 17, 2018
    Location:
    Texas
    I'll rephrase for him in a slightly more tactful way:

    If you want help from a forum that uses words to communicate it would be best if you chose your words thoughtfully and clearly presented the problem and possibly what you've tried to remedy it.

    nobody wants to whip out a Rosetta stone to try and help a guy. help us help you.
     
  8. Phillip Scocca

    Phillip Scocca Member Established Member

    Messages:
    32
    Joined:
    Aug 4, 2019
    Location:
    Long Island
     
  9. Phillip Scocca

    Phillip Scocca Member Established Member

    Messages:
    32
    Joined:
    Aug 4, 2019
    Location:
    Long Island
    I start the car it runs perfect then after a few minutes it runs rough like it runs on half the cylinders the check engine light comes on then off I put my tester in and it reads nothing no codes , I replaced the wires, coil packs, spark plugs, connectors to the coil packs none of that helped and I’m stuck now I’m not sure what else to try
     
  10. Tillerman77

    Tillerman77 Active Member Established Member

    Messages:
    270
    Joined:
    Aug 28, 2016
    Location:
    Minnesota
    Not an expert on code readers, but I think some readers can access older codes even if the engine light has gone out. In other words, if the light has come on and then gone out there should be a code in history that some reader can show.
     
  11. Makobra

    Makobra Well-Known Member Established Member

    Messages:
    373
    Joined:
    Nov 17, 2018
    Location:
    Texas
    Question: when it starts running like crap if you floor it does it get over itself and rev good?

    If yes then I think you've got a bad 02 sensor. its perfect at startup right? then the sensor heats up and the pcm starts trying to use it but the sensor is fragged so the readings are bad so the computer probably tells the injectors and coils to do the wrong stuff.

    your front O2 sensors do this (before the cats) so I would replace them and see what happens.

    the same thing happened with my 94 f150 with a 302, it would stumble and when i floored it the truck would run like a scalded dog. it was very strange but a new 02 sensor fixed her right up.
     
  12. xblitzkriegx

    xblitzkriegx Well-Known Member Established Member

    Messages:
    839
    Joined:
    May 24, 2010
    Location:
    Earth
    Also inclined to agree with O2 sensor but it should show a code.

    Take it to a parts store and have them uabj the codes. Some stores have better readers than others.
     
  13. Phillip Scocca

    Phillip Scocca Member Established Member

    Messages:
    32
    Joined:
    Aug 4, 2019
    Location:
    Long Island
    When I rev it it dosent change at all it dosent get over itself very strange
     
  14. Makobra

    Makobra Well-Known Member Established Member

    Messages:
    373
    Joined:
    Nov 17, 2018
    Location:
    Texas
    unplug the maf and start the car. tell us what happens.
     
  15. Phillip Scocca

    Phillip Scocca Member Established Member

    Messages:
    32
    Joined:
    Aug 4, 2019
    Location:
    Long Island
    Okay will do I’m in PA now I will be back Saturday
     
    Makobra likes this.
  16. Makobra

    Makobra Well-Known Member Established Member

    Messages:
    373
    Joined:
    Nov 17, 2018
    Location:
    Texas
    cool. BTW when you revved it did you go wide open throttle? because you have to do that for it to switch to the fuel map and stop using the O2 sensors.
     
  17. Phillip Scocca

    Phillip Scocca Member Established Member

    Messages:
    32
    Joined:
    Aug 4, 2019
    Location:
    Long Island
    Yeah it was revved all the way to the floor no change
     
  18. Phillip Scocca

    Phillip Scocca Member Established Member

    Messages:
    32
    Joined:
    Aug 4, 2019
    Location:
    Long Island
    I hope it’s not like a dead cylinder or anything the cars all stock
     
  19. Makobra

    Makobra Well-Known Member Established Member

    Messages:
    373
    Joined:
    Nov 17, 2018
    Location:
    Texas
    and it runs perfectly fine when cold?
     
  20. Phillip Scocca

    Phillip Scocca Member Established Member

    Messages:
    32
    Joined:
    Aug 4, 2019
    Location:
    Long Island
    On start up it runs good hot or cold then out of nowhere is does it gets weird
     

Share This Page