• Welcome to SVTPerformance!

2015-16 style tail lights for 10-12

Discussion in 'Interior and Exterior' started by madscotsman, Jan 19, 2018.

  1. madscotsman

    madscotsman Active Member Established Member

    Messages:
    280
    Joined:
    Aug 22, 2012
    Location:
    USA
    Looks like AM has some new Raxiom taillights for the 10-12 crowd:

    https://www.americanmuscle.com/raxiom-vector-tail-lights-red-diffusers-1012.html

    Pretty sure I HATE the reflectors and reverse light along the bottom but will withhold judgment until I actually see them on a car. Seems like they could have found a 10-12 around their shop to install them on for pics?!?!? They have white, smoked white, and red, but no option for smoked red diffusers....
     
  2. madscotsman

    madscotsman Active Member Established Member

    Messages:
    280
    Joined:
    Aug 22, 2012
    Location:
    USA
    Sorry for the long post, Rant on........

    Bought a set of these. They do not work well with existing LED front turn signals apparently. I have LED switchbacks in my front turn signals with the appropriate load resistors. These LED taillights cause my turn signals to hyperflash occasionally now. Not sure how they are different than the OEM LED taillights that came standard on the 12's, that I replaced these with?? I Called AM which was as useful as smashing myself in the face with a hammer. First rep was a chick that had NO car/electrical knowledge and had to keep getting help from someone else to TRY to answer my questions. She told me I needed load resistors on the front turn signals??!!??!! Told her I already had them and I gave up trying to get help that day and got off the phone. She/AM then sent me free load resistors in the mail. Called back a few days later an spoke with a guy that told me I needed to put the incandescent bulbs back in the front of the car to use the LED tail lights which makes no sense. How did they work with the OEM LED tail light bulbs for the past 2+ years? IS anyone familiar with the OEM wiring and enough with electrical to know if it would possibly fix the issue if I either put the new load resistors somewhere in the tail light harness, or just removed the front lights load resistors??????
     

    Attached Files:

Share This Page