• Welcome to SVTPerformance!

2015 non pp ptu issues

Discussion in 'Gen IV Taurus SHO' started by The Sweaty Potato, Jun 9, 2017.

  1. The Sweaty Potato

    The Sweaty Potato New Member

    Messages:
    1
    Joined:
    May 27, 2017
    My ptu went out at 26k is this normal? My 2015 SHO was overheating the ptu fluid I asked the dealer what the problem was they said you either get a good ptu or a bad one I heard that the pp SHO has a liquid cooled ptu any thoughts ? My car is stock no programmer nothing and not abused!


    Sent from my iPhone using the svtperformance.com mobile app
     
  2. Pale Snake

    Pale Snake Member Established Member

    Messages:
    219
    Joined:
    Oct 27, 2003
    Location:
    Rhode Island
    Good rule of thumb is to swap the fluid every 30k, esp if modded or seeing track time.
     
  3. 93 347 Cobra

    93 347 Cobra Well-Known Member Established Member

    Messages:
    2,315
    Joined:
    Dec 5, 2002
    Location:
    Denver
    OPs failed at 26k. No, it's not normal. He didn't even make it to 30K to get to the change interval.

    Can anyone post a link to the tech write-up on how to change?
     
  4. Pale Snake

    Pale Snake Member Established Member

    Messages:
    219
    Joined:
    Oct 27, 2003
    Location:
    Rhode Island
    Didn't even make the 30k really sucks, been flushing fluid since picking up my 2010 SHO arguing with folks telling me it was "lifetime" fluid. Best luck I had was using a manual pump removing as much as possible of the the warmed up fluid then pumping clean fluid in starting with Mobil-1 gear oil then when it runs clear let it drain until you can do the old school pinky test on the fill hole. This year I was fed up with the messy extra work so I ended up installing a drain plug. Good luck!
     
  5. Pale Snake

    Pale Snake Member Established Member

    Messages:
    219
    Joined:
    Oct 27, 2003
    Location:
    Rhode Island
    This is a video I used as reference.
     

Share This Page