• Welcome to SVTPerformance!

2nd Gear shift issues.

Discussion in 'Driveline' started by 2012Ridge, Feb 10, 2018.

  1. 2012Ridge

    2012Ridge Member Established Member

    Messages:
    77
    Joined:
    Nov 22, 2013
    Location:
    Pittsburgh
    Okay so this spring i'm gonna try to address this issue. The car has an extremely heavy clutch.
    Actually had a stress fracture from driving it in my foot lol. Seems to be way too heavy. It's a Ram HD i believe. The car has issues engaging into first sometimes at a stop. I've adjusted the cable adjuster several times nothing seems to help that. Only happens here and there. But the real issue is 2nd gear as stated in the title. It seems fine when car is cool. But once warmed up it gives me issues at high rpm going from first to second. Basically anything over 4k. It's like you're locked out. So I've googled and looked around but still not sure what to think. Car has new clutch cable, upr quadrant, MGW Orange handle, Tried new trans fluid Syncromesh from what i saw people raving about during my googles. That didnt change anything. So basically what do you guys think? Syncro? Shifter? Clutch/Pressure plate? Any help would be greatly appreciated. Oh and if i just drive casually there is np.
     
  2. me32

    me32 BEASTLY SHELBY GT500 TVS Moderator

    Messages:
    15,607
    Joined:
    Sep 6, 2005
    Location:
    CA,NorCal
    How many miles on the car? If it has high miles more than likey is worn and needs a rebuild. Other thought is the clutch may not be setup correctly.
     
  3. KLLR SNK

    KLLR SNK Active Member Established Member

    Messages:
    923
    Joined:
    Oct 15, 2012
    Location:
    The Prairie State
    What is your power level? Just a guess, but it sounds like it could be your pressure plate may be too weak or worn and collapsing at the higher rpm range so it doesn't release the clutch disc for the shift.
     
    1wild-horse likes this.
  4. olympic

    olympic Well-Known Member Premium Member Established Member

    Messages:
    1,538
    Joined:
    Dec 28, 2014
    Location:
    SK, Canada
    Mine was exactly the same-extremely heavy pedal and trouble shifting at high RPM. I was never able to 100% isolate the problem but when I removed the trans and clutch I noticed the PP had a lot of hot spots on it. My theory is that the clutch was not releasing fully. I've since installed an RXT and a Magnum but haven't driven it since it's still winter here for a while yet. Clutch pedal is light as feather now though! :)
     
  5. 2012Ridge

    2012Ridge Member Established Member

    Messages:
    77
    Joined:
    Nov 22, 2013
    Location:
    Pittsburgh
    40k miles and car has just a 2.93 pulley and intake/exhaust.
    Also has a brand new rear end. Everything was replaced, Full tilt boogie racing kit as well.
     
    Last edited: Feb 10, 2018
  6. 2012Ridge

    2012Ridge Member Established Member

    Messages:
    77
    Joined:
    Nov 22, 2013
    Location:
    Pittsburgh
    Any ideas?
     
  7. KLLR SNK

    KLLR SNK Active Member Established Member

    Messages:
    923
    Joined:
    Oct 15, 2012
    Location:
    The Prairie State
    It could be a lot of things or a combination of things. To name a few; wrong tb, poorly adjusted ball, broken/cracked springs on clutch disc/pp, grease/hot spots on clutch/pp/flywheel, warped flywheel/pp. That is where my inspections would begin.
     
  8. 98 svt

    98 svt Premium Member Premium Member Established Member

    Messages:
    18,333
    Joined:
    May 16, 2005
    Location:
    Nunya, MA
    1wild-horse and me32 like this.
  9. me32

    me32 BEASTLY SHELBY GT500 TVS Moderator

    Messages:
    15,607
    Joined:
    Sep 6, 2005
    Location:
    CA,NorCal
    Time to pull it out and check
     
  10. hotcobra03

    hotcobra03 Well-Known Member Established Member

    Messages:
    6,650
    Joined:
    Mar 11, 2007
    Location:
    poteet,texas
    heavy?

    is it super hard to push pedal? more than normal.

    I had issue with hard to push/stiff..

    I had a hard time with all gears..even trying to shift without clutch..

    after replacing every thing I still had problem..

    I did find my issue,,binding clutch cable..new

    I pulled cable..flooded it with wd 40..

    re installed, been very easy to shift and pedal to push
     
    me32 likes this.

Share This Page