• Welcome to SVTPerformance!
ATTENTION!
You may experience intermittent issues while accessing the site over the next 60-90 minutes, as we perform maintenance and upgrades.

Anyone running 305/40-18's on the rear and if so any issues? Thanks

Discussion in 'SVT Shelby GT500' started by ///Bruce, Dec 29, 2014.

  1. ///Bruce

    ///Bruce ///Bruce Established Member

    Messages:
    152
    Joined:
    Dec 10, 2011
    Location:
    Houston
    I want to get into a set of Nitto NT555R's. Specifically, 305/40-18's rather than 305/45-18's. The OD is almost perfect. But the Nitto site says the minimum width of the rim starts at 10", not 9.5".

    B.
     
  2. fullboogie

    fullboogie Well-Known Member Established Member

    Messages:
    2,590
    Joined:
    Dec 6, 2004
    Location:
    Texas
    I ran those for a couple of years with no issues as far as rubbing - but even aired down to 25psi they wore in the middle rather quickly due to rim width. On a related note, be aware that all the national tire chains (NTB, Discount, etc) cracked down this year on installing tires on rims that are less than the recommended width. Specifically, they will not install a 305 on factory rims under any circumstances, even if you claim they are for weekend track duty. I just went through this recently, and had to go with 285's. I'm sure if I'd taken the time to find an independent tire shop, I could have had 305's installed. But the premature wear problem prompted me to try the 285's for a change.
     
  3. ///Bruce

    ///Bruce ///Bruce Established Member

    Messages:
    152
    Joined:
    Dec 10, 2011
    Location:
    Houston
    Thank you
     

Share This Page