• Welcome to SVTPerformance!

Belt slip issue, 2.9L whipple cobra. Any help appreciated

Discussion in 'The Blower Bistro' started by Kwik03DSG, Jun 11, 2013.

  1. Kwik03DSG

    Kwik03DSG New Member Established Member

    Messages:
    716
    Joined:
    Nov 18, 2010
    Location:
    San Antonio, Texas
    Ok I have an issue I need help solving, all guys with 2.9L/3.4L whipples feel free to chime in.

    My car was in the process of getting tuned and has massive belt slip after 5300-5400 rpm. car noses off from 26.5psi at 5400 to 14psi. (Made 690whp at that point, so much more to be had )

    The blower is a 2.9L whipple Crusher with a caged 2lb lower and 2.8 Reichard Racing upper pulley. The car also has 3 Billetflow idlers, 2x90mm and 1x100 mm pulley. Belt was a new Gates K080755 belt. Tensioner is a Reichard manual tensioner with spring.

    In short, other than going to the K080755 HD version, is their anyway to cure the slipping? Kind of lost on this, as I thought I had taken the necessary precautions to avoid this.


    Fire away with any suggestions, thanks (and yes I did search. Saw YZFkid's thread and 2 others, not much info when dealing with belt slip from larger displacement blowers)
     
  2. Crusher9008

    Crusher9008 New Member Established Member

    Messages:
    434
    Joined:
    Dec 26, 2011
    Location:
    Warren, MI
    I'm having the exact same issue, 2.9 w/ 4lb lower with a gates belt Richard racing tensioner with metco idlers ... Boost is dropping significantly around 4800 in 3rd gear
     

Share This Page