• Welcome to SVTPerformance!

Car pulls hard to either side after suspension upgrades and alignment

Discussion in 'Driveline/Suspension' started by Despair, Jun 24, 2019.

  1. Despair

    Despair New Member Established Member

    Messages:
    15
    Joined:
    May 5, 2013
    Location:
    LaPlace, LA
    So I recently had many of my outdated suspension mods replaced to the following:
    BMR drag springs (front and rear)
    Strange adjustable shocks and struts
    BBK caster/camber plates
    Steeda adjustable UCA
    New factory bumpstops
    I noticed that before I had the camber plates installed, the negative camber from the car being lowered was causing some pretty gnarly inside tire wear, which was the main reason I went ahead and spent the money on the plates this go around. After the install, it seemed that due to the corrected camber, the driver side tire was now rubbing against the fender well whenever to turned hard to either side. I also noticed that the car would pull pretty hard to whatever side I had last turned the car hard to until I turned it hard the other way. The mechanic that installed the suspension components told me after that I would have to get an alignment which he didn't do, so I took the car to my local Ford dealership over the weekend and had them install 2 slightly skinnier, slightly lower profile tires on the front as well as perform a front end alignment. Now the tires don't seem to be rubbing but the car still pulls hella hard to either side depending which way I last turned hard. Is there something going on with the components I installed or did Ford half-ass my alignment?
     
  2. Despair

    Despair New Member Established Member

    Messages:
    15
    Joined:
    May 5, 2013
    Location:
    LaPlace, LA
    Car is a 2012 GT btw
     

Share This Page