• Welcome to SVTPerformance!

Cobra clicking, don't know what it could be

Discussion in 'SN95 Cobras' started by SVTnv, Nov 10, 2002.

  1. SVTnv

    SVTnv The original Dr. Evil Established Member

    Messages:
    299
    Joined:
    Oct 8, 2002
    Location:
    yup
    the last couple times i've driven it, it's been making a noticeable ticking noise. now i haven't been getting on it at all since it started because i also notice that there isn't as much power there either, there's just not as much pop when i stab the throttle. the noise is only there when i accelerate at any speed, not when i'm just cruisin. and when it first started i had just ran it pretty hard and i had some thin white smoke come out the back and it smelled inside the car. i'm thinking it has something to do from the S/C and the strain it's putting on the engine. my plans are that since it's going to be stored next weekend until approx. mid March, that i'll just get a complete engine check and get it fixed then.

    what do you think it is? i'm worried about what to do. but i won't be driving it anymore this year for sure.
     
  2. Redsnk95

    Redsnk95 New Member Established Member

    Messages:
    141
    Joined:
    Dec 18, 2001
    Location:
    Houston, TX
    sticky lifter maybe...what year cobra do you have?

    Troy
     
  3. SVTnv

    SVTnv The original Dr. Evil Established Member

    Messages:
    299
    Joined:
    Oct 8, 2002
    Location:
    yup
    '95, i talked to my cousin this afternoon who's had the same problem in his '93 GT. i think i've got a small valve leak on the side where the blower is. the oil was changed about 1k miles ago and the oil was about a quart low, so i think i've been leaking a little. it's going in tomorrow to get checked out.
     

Share This Page