• Welcome to SVTPerformance!

Converter advice

Discussion in 'New Edge Cobras' started by persico, Oct 6, 2018.

  1. persico

    persico Member Established Member

    Messages:
    58
    Joined:
    Sep 18, 2018
    Location:
    Buffalo, NY
    Looking for some advice on a lock up converter for my 4R70W trans in my 01 GT. I've tried two single disc lock up converters from two well known converter companies and both took a shit with very few passes on them. Converter locks up and kills the engine when putting it in gear when they take a crap. I'm putting down 500rwhp (approx). I leave the line at idle in drive and the trans shifts itself. As far as I know it's not supposed to lock up the clutch at WOT so I'm not exactly sure why the converters are failing.

    Anyone have a similar problem? What converter did you end up going with. Please explain.
    Thanks....
     
  2. 01yellercobra

    01yellercobra AKA slo984now Established Member

    Messages:
    16,513
    Joined:
    Oct 5, 2005
    Location:
    San Diego
    Is the car tuned? If so have you talked to your tuner about the lock up settings?
     
  3. persico

    persico Member Established Member

    Messages:
    58
    Joined:
    Sep 18, 2018
    Location:
    Buffalo, NY
    Funny you should mention that. I had a call into my tuner and he just got back to me yesterday. I guess I screwed up, he's going to go back and look at my tune but he's pretty sure he had the converter locking up just after going into second gear but after reaching its flash point (3800). I heard from some this shouldn't be an issue but since I've fried two units so far I'm inclined to think otherwise.

    Also do you think it would be better to leave the converter settings alone and go with a triple disc unit or stick with the single disc and keep it unlocked? I plan on calling Chris at Circle D but I'd appreciate any advice you may have. I'm not to familiar with these tranny's. Thanks again!
     
    Last edited: Oct 7, 2018
  4. 01yellercobra

    01yellercobra AKA slo984now Established Member

    Messages:
    16,513
    Joined:
    Oct 5, 2005
    Location:
    San Diego
    Unfortunately I'm not much help. I have messed with autos since I was a teen. Maybe try the driveline forum for the Terminators. Or see what Circle D says. They might even have tune setting for you.
     
  5. persico

    persico Member Established Member

    Messages:
    58
    Joined:
    Sep 18, 2018
    Location:
    Buffalo, NY
    Okay will do thanks.....
     
  6. Stanger00

    Stanger00 Well-Known Member Established Member

    Messages:
    2,981
    Joined:
    Oct 25, 2011
    Location:
    Concord, CA
    I had a single disk with 400hp from lentech that I bought used. If I remember it was previously used with a nitrous 2 valve and I ran a vortech 2 valve.

    The tuners I used kept stock schedule. No lockup in 2nd at WOT and when it locked in 3rd around 90mph at WOT, rpms would drop by about 500 or so.

    I have a circle-D triple disk and that thing grabs like another gear when it locks and no rpm drop at all anymore. Have the same lockup at 90mph.



    Sent from my iPhone using Tapatalk
     
  7. KEVINS

    KEVINS Well-Known Member Established Member

    Messages:
    521
    Joined:
    Jan 11, 2014
    Location:
    EARTH
    Make sure it's unlocked during the 2-3 shift then have it lock back up after the shift is completed.
    I run a triple disc Precision unit but I also use a Quick4 controller to control it.

    ks
     
  8. lOOKnGO

    lOOKnGO Keep'um smiling Established Member

    Messages:
    4,207
    Joined:
    Oct 1, 2009
    Location:
    White Post, Va
    Never an issue with my Circle D. Keep us updated!


    Sent from my iPhone using Tapatalk
     
  9. persico

    persico Member Established Member

    Messages:
    58
    Joined:
    Sep 18, 2018
    Location:
    Buffalo, NY
    Thanks for the help guy's. I really appreciate it. From what I understand you pretty much need a triple disc unit if you're going to lock it up at WOT. Wish I new that before I put the last converter in it. Anyway, I've got a triple disc unit on order. Not sure I'll have any more updates this year, the tracks close soon. We'll see. Thanks again!
     
    Stanger00 likes this.
  10. persico

    persico Member Established Member

    Messages:
    58
    Joined:
    Sep 18, 2018
    Location:
    Buffalo, NY
    Update: First a little background. I had a single disk lockup PI converter in the car when I purchased it. It would just about stall the engine when putting it in gear. I wasn't getting any codes so I decided to change the converter. I put a single disk FTI unit in and it fixed the problem, the car ran great. After driving the car for a week and 3 quarter mile passes it locked up again when putting it in gear but this time I was getting a code for the TCC solenoid and my OD light was flashing on and off. I replaced the TCC solenoid which got rid of the code but the converter was still locked. By the way I was told by several experts that the converter cannot lock in drive at idle - WRONG!

    About this time my tuner got back to me and told me he had the converter locking up in second and third gear after the converter reached it's flash speed (3800). After talking to a few well known converter companies, they recommended a triple disk lock up with my HP level (approx 500rwhp) and said a single would not hold up, something my tuner should have known but didn't (wont be using him anymore) I went with the FTI triple disk unit. I changed the converter but it was still locked up in gear stalling the engine! (remember I was still getting no codes). After talking to a friend of mine we decided to pull the ten pin connector (only 7 pins are used) which powers the solenoids and TCC and check for voltage. THE CONNECTOR WAS FULL OF TRANSMISSION FLUID! It came up through the connector from the pan.

    My buddy cleaned it all up and presto no lockup when putting it in gear. Drove the car around and it's shifting great.
    To change the case connector (round black connector - right rear of trans) you have to pull the valve body out of the trans! The good news is that the connector is less than 20 bucks. Now here's the kicker, I talked to ALL the experts when trying to solve this issue and NOBODY had a clue. Only when I did a google search did I find out this was not that uncommon but by that time I already had it fixed. So an important tip, if your 4R70W starts acting up for no reason and your not getting any codes check the 10 pin connector. I can't even begin to say how pissed off I am at Ford for such a shitty [email protected]#*in design!!!! Thanks and I hope this will help someone avoid what I went through. I miss my C-4 :)
     
    Last edited: Oct 27, 2018

Share This Page