• Welcome to SVTPerformance!

Driveline tick or click?

Discussion in '2012-2013 Boss 302 Mustang' started by Yellowvenom, Oct 13, 2018.

  1. Yellowvenom

    Yellowvenom Member Established Member

    Messages:
    129
    Joined:
    Mar 23, 2011
    Location:
    Los Angeles CA
    Hello Boss brothers and sisters.

    My 2013 with 11k miles has developed a driveline tick when accelerating. It only occurs after the car has been driven for 15-20 minutes and everything is up to temp. It’s not RPM dependent. Not an exhaust leak either. Easiest to hear when driving next to something like another car or wall, even the curb. I’m thinking driveshaft (u-joint or CV) maybe a rear wheel bearing. Any input is appreciated!
     
    Last edited: Oct 13, 2018
  2. KBBoss302

    KBBoss302 Active Member Established Member

    Messages:
    369
    Joined:
    Mar 21, 2012
    Location:
    Texas
    Interesting - my 2012 Boss did the same thing but my 2013 doesn't! I had forgotten all about that ticking until reading your thread. I never figured it out so I am zero help, unfortunately!
     
  3. Mojo88

    Mojo88 "Hammer" Time Established Member

    Messages:
    688
    Joined:
    Jan 30, 2017
    Location:
    RI
    With a paltry 11k miles, it's hard to imagine driveline components worn out, but anything is possible. However, if you drive it hard, then I could easily see something in engine/trans causing a problem.

    I might suggest a different approach. This same mysterious type of noise has happened to me numerous times. Your comments about "Easiest to hear when driving next to something like another car or wall..." really caught my attention, and reminded me that the last time I had this type of noise, it ended up being a large nail head in a tire. So I would say to thoroughly inspect each tire to see if something jammed in the rubber. Perhaps it doesn't make noise until the rubber warms up a little bit.
     
  4. _Snake_

    _Snake_ Well-Known Member Established Member

    Messages:
    2,078
    Joined:
    Jan 21, 2014
    Location:
    Flo-Rida
  5. KBBoss302

    KBBoss302 Active Member Established Member

    Messages:
    369
    Joined:
    Mar 21, 2012
    Location:
    Texas
    Not sure about the OP, but that wasn't the noise I had. Seemed to come from the back half of the car and only happened when moving and sped up as you gained speed. Probably something related to driveshaft was always my guess.
     

Share This Page