Finally got one…after 20 years of waiting…

BlksvtCobra01

Deplorable and Proud
Established Member
Joined
Apr 10, 2008
Messages
13,589
Location
Ohio
Congratulations, sharp Terminator and Comanche.


Sent from my iPhone using Tapatalk
 

CobraVenom01

Well-Known Member
Established Member
Premium Member
Joined
May 26, 2006
Messages
1,956
Location
Clearwater FL
Got the new belt on. Has about 1/4” of play feels nice and tight. Lower pulley is 8” so looks like it’s a 2lb lower? Ill get a picture of it this afternoon. It’s a metco set up
401003456da3bd4f85bad45d3ef0c2f3.jpg


f54e5fb09e340a364a07a9bb1618b0ef.jpg



Sent from my iPhone using Tapatalk
 

CobraVenom01

Well-Known Member
Established Member
Premium Member
Joined
May 26, 2006
Messages
1,956
Location
Clearwater FL
The pictures make it look closer than it is there is room between the belt. Also I measured the lower again from underneath with the car jacked up. It’s definitely stock size. It’s under 8”


Sent from my iPhone using Tapatalk
 

TBCobra

Well-Known Member
Established Member
Premium Member
Beer Money Bros.
Joined
Feb 15, 2008
Messages
9,260
Location
SC
Silver looks so good on these cars. Late to the party but congrats, looks clean.
 

fitforspeed

Active Member
Established Member
Joined
Oct 10, 2012
Messages
535
Location
Central Florida
Nice find! Looks like you found one with a great base to build on. Glad to have another Terminator in Fl.


Sent from my iPhone using svtperformance.com
 

BOOGIE MAN

Logic and Reason
Established Member
Joined
Feb 10, 2005
Messages
8,244
Location
Under the bed
I’ll just leave this here, gonna be a long 6 weeks

281892bd1f00411a91cccd255f9b4115.jpg



Sent from my iPhone using Tapatalk
A couple of my favorite wallpapers are a silver terminator with those ccws and coilovers, think i got from this site many moons ago. One pic was taken at an airport with a plane in the background.

I'm expecting a similar shot at KPIE from you Ryan
 

CobraVenom01

Well-Known Member
Established Member
Premium Member
Joined
May 26, 2006
Messages
1,956
Location
Clearwater FL
Well, alternator died yesterday lol it was a PA Performance unit.

Took the car to get my daughter from school and was idling in car line. After about 10 min it started running rough, temp started creeping up, iat2 started getting hot.

Looked at me aeroforce gauge and I was at 12.6 volts.

Limped it home and made it to my garage with 11.7 volts.

I have a new KMJ titan with big 3 wire upgrade on my work bench. Installing it sooner than I thought lol


Sent from my iPhone using Tapatalk
 

Users who are viewing this thread



Top