• Welcome to SVTPerformance!
ATTENTION!
You may experience intermittent issues while accessing the site over the next 60-90 minutes, as we perform maintenance and upgrades.

Fuel gauge stopped working after PPVR Delete

Discussion in 'Terminator Talk' started by Nervouswreck, Aug 17, 2019.

  1. Nervouswreck

    Nervouswreck Active Member Established Member

    Messages:
    363
    Joined:
    May 5, 2015
    Location:
    Pennsylvania
    So i did my PPRV delete and i fixed my hesitation issue perfectly, but now after i did my first fill up on my tank , the needle went up to full for a second then fell right back down to empty and won’t work , plus my check engine light came on with the low fuel light too . I checked the code for the check engine light and indeed it’s for fuel . So i dropped the tank today and removed the hat , everything looks ok but the arm/float seems like it has no resistance in it and it clicks when i move it up and down too . Is that normal?

    What could be the issue ? The float ?



    Sent from my iPhone using the svtperformance.com mobile app
     
  2. CompO_Eric

    CompO_Eric Arch Enemy of the Prius Established Member

    Messages:
    823
    Joined:
    Apr 27, 2010
    Location:
    West Virginia
    Might want to replace the arm. IIRC the float is grounded to the the brace on the pump. You should be able to measure resistance and see a change as the float arm moves.


    Sent from my iPhone using svtperformance.com
     
    me32 and Nervouswreck like this.
  3. gt347mustang

    gt347mustang Well-Known Member Established Member

    Messages:
    2,446
    Joined:
    Jun 29, 2006
    Location:
    Colorado
    Replace the sender.
     
    me32, roy_1031 and Nervouswreck like this.
  4. 03' White Snake

    03' White Snake Well-Known Member Established Member

    Messages:
    3,011
    Joined:
    Feb 5, 2007
    Location:
    Mass
    Check the little yellow wire on sender. Sounds like you broke it. I re-soldered mine when I broke mine. The float does not have steps, it will move smoothly.

    20180814_192421_zpsh57kmttf.jpg

    20180814_192117_zpselnzr66j.jpg

    20180814_193857_zpsjavueuhy.jpg
     
    Last edited: Aug 18, 2019
    Nervouswreck and Bdubbs like this.
  5. Bdubbs

    Bdubbs u even lift bro? Premium Member Established Member

    Messages:
    14,322
    Joined:
    Jan 8, 2010
    Location:
    MN
    Nervouswreck likes this.
  6. Nervouswreck

    Nervouswreck Active Member Established Member

    Messages:
    363
    Joined:
    May 5, 2015
    Location:
    Pennsylvania
    Mine clicks bad when it moves . I already ordered one from Tasca , the wire was fine . Thank you very , very much for the pics and now i know what to look for in the future


    Sent from my iPhone using the svtperformance.com mobile app
     
  7. Nervouswreck

    Nervouswreck Active Member Established Member

    Messages:
    363
    Joined:
    May 5, 2015
    Location:
    Pennsylvania
  8. Nervouswreck

    Nervouswreck Active Member Established Member

    Messages:
    363
    Joined:
    May 5, 2015
    Location:
    Pennsylvania
    Found this is my sending unit today , I’d say it’s toast


    Sent from my iPhone using svtperformance.com
     

Share This Page