• Welcome to SVTPerformance!
ATTENTION!
You may experience intermittent issues while accessing the site over the next 60-90 minutes, as we perform maintenance and upgrades.

guys with new trickflow heads please help

Discussion in '2nd Generation' started by blacknite51, Apr 8, 2010.

  1. blacknite51

    blacknite51 New Member Established Member

    Messages:
    101
    Joined:
    Jun 1, 2008
    Location:
    Wisconsin
    So i went and picked up my longblock today...built bottom end obviously. my question is when i was goin to put the timing chain cover on the bolts that would normally screw into the heads are to big, so now what do i do.and i cant just put regular bolts in because i need the stock ones so i can mount the pulley bridge to it. my other question-there was a sheet that came with them that said i need to get a different bracket for the oem power steering reservoir and it gave me the trickflow part number and everything and i went on the website and nothing. any help is much appreciated. thanks guys
     
  2. ChrisDeluxe

    ChrisDeluxe New Member Established Member

    Messages:
    323
    Joined:
    Jan 1, 2008
    Location:
    Cologne, Germany
    The stock screws are M10 to hold the chain cover and M8 to mount the pulley bridge. You need complete M8 screws to install the front cover. I don´t know if the screws build from Ford or Trickflow for the conversion too. I have build them by myself. You will also need normal M8 screws to hold the pipe from the water pump in back of the heads!!

    The power steering reservoir is also mounted on the throttle body and on top of the thermostat body. I think that might be enough. But I have no testdrive yet, hopefully at this weekend!!
     
    Last edited: Apr 9, 2010
  3. 02REDSVT

    02REDSVT alienfreek Established Member

    Messages:
    1,582
    Joined:
    May 26, 2007
    Location:
    SoCal
    I believe the Ford Part number is -N806300-S431 for the timing cover bolts with the stud on the end.... the regular bolt PN is -N806177-S437
     
    Last edited: Apr 9, 2010
  4. blacknite51

    blacknite51 New Member Established Member

    Messages:
    101
    Joined:
    Jun 1, 2008
    Location:
    Wisconsin
    thanks for the input guys. anyone have pics of the power steering reservoir after mounting it
     
  5. flashlight

    flashlight New Member Established Member

    Messages:
    396
    Joined:
    Jan 29, 2008
    Location:
    ellabell G.A.
    I had the same problem with the timming cover bolts when I put romeo heads
    on mine. I just went to a junk yard and got some off a 4.6.
     
  6. RMoore92

    RMoore92 Active Member Established Member

    Messages:
    1,206
    Joined:
    Apr 4, 2008
    Location:
    Chandler, Arizona
    I did this! Worked out perfectly!
     
  7. ChrisDeluxe

    ChrisDeluxe New Member Established Member

    Messages:
    323
    Joined:
    Jan 1, 2008
    Location:
    Cologne, Germany
    To go to a junk yard is perfect and simple! I´m a bit jealousy of you guys, cause if I go here to a junk yard and ask for the screws I will become ????? [​IMG]

    Greetings from Germany!!
     

Share This Page