Motor Mounts

amnpalm

New Member
Established Member
Joined
Dec 23, 2002
Messages
33
Location
Atlanta
Just get finished installing new motor mounts on my '97 Cobra and it feels great to saving over $1200, that's what Ford was going to charge me. Car drive tons better, like new again. Advice to you do it yourselfs, The starter and a pisser, and once you fish out the old mounts the new ones are very hard to get back in. I had to take off about 1/4 inch of the threads to fish them back into place. Other then that it was a very straight forward repair and took alittle 6 hours start to finish. Next time it'll take 4 hours, but hopefully there will not be a next time. The old mounts were totally wasted. :-D
 

97CasperCobra

Track is Crack
Moderator
Joined
Nov 21, 2000
Messages
5,804
Location
Houston, TX USA
Props to you for doing them yourself man. :thumbsup:

When the dealership installed my engine, I specifically told them to change out the mounts. They didn't and upon starting the engine felt like it shook the whole car. Turned it around and made them give me new mounts!!! :coolman:
 

28

postin the midnight oil..
Established Member
Joined
Jan 5, 2003
Messages
4,595
Location
Texas is the best..
Originally posted by amnpalm
Just get finished installing new motor mounts on my '97 Cobra and it feels great to saving over $1200, that's what Ford was going to charge me. Car drive tons better, like new again. Advice to you do it yourselfs, The starter and a pisser, and once you fish out the old mounts the new ones are very hard to get back in. I had to take off about 1/4 inch of the threads to fish them back into place. Other then that it was a very straight forward repair and took alittle 6 hours start to finish. Next time it'll take 4 hours, but hopefully there will not be a next time. The old mounts were totally wasted. :-D

Got any pics of your old mounts?Oh,and how many miles on your ride?Maybe it's time to check mine out...:shrug:
 

97CasperCobra

Track is Crack
Moderator
Joined
Nov 21, 2000
Messages
5,804
Location
Houston, TX USA
Re: Re: Motor Mounts

Originally posted by 28 fangs
Got any pics of your old mounts?Oh,and how many miles on your ride?Maybe it's time to check mine out...:shrug:

Don't have any pics of my old motor mounts, but they were all worn and cracked. I had 60K miles. Hope this helps.
 

28

postin the midnight oil..
Established Member
Joined
Jan 5, 2003
Messages
4,595
Location
Texas is the best..
I'm right at 49k right now...Maybe when I get to 60K I will also check them out...thanks for the info....
 

amnpalm

New Member
Established Member
Joined
Dec 23, 2002
Messages
33
Location
Atlanta
This is my thinking, at 49000 miles I had the clutch replaced by a friend that had a shop. The manual stated that if you remove the transmission you should support the engine form the top, so that the mounts don't get to much stress and crack. After the clutch was install I did feel a small vibration on the high rpm range, but blow it off thinking it was the King Cobra clutch. The car now has 80000 miles, and it got really bad about 1000 miles ago. I think that's when I broke the other mount. I'll take a pic's this weekend and post. On one mount the rubber is total blown out, and when a was removing them rubber was falling into my face. Have a good weekend Later.
 

STAMPEDE3

SAULS BROTHER
Super Moderator
Joined
Apr 5, 2003
Messages
26,998
Location
South Louisiana
Just changed mine last week, also just turned 60,000 last week. mounts were shot. My cousin did it, parts and labor $250, He didn't cut the 1/4 inch off, he dropped the
k member a little.
 

Users who are viewing this thread



Top