Nbrac27's 04 SY Terminator

Nbrac27

Active Member
Established Member
Joined
Apr 5, 2018
Messages
136
Location
Fort Bragg, NC
Now that the car overheated again for some mysterious reason that has just as mysteriously been fixed, I'm paranoid.

So question for you all. I have my unmarried X4 that I plan to use in the future when I get the car returned.

But, can I marry it to the car now without it wiping my current tune, simply so I can monitor the temp gauge reading so I can see the instant it starts climbing if it happens again.

How I understand it is as long as I don't load a new tune, the X4 will simply save my current tune as the "stock tune", and I'd be fine, right?
 

Nbrac27

Active Member
Established Member
Joined
Apr 5, 2018
Messages
136
Location
Fort Bragg, NC
Took her to the local C&C, still no cooling or leaking issues.

No idea what the problem was, but going on 3 days of it being fixed now.. it's a damn mystery

But on the plus side, C&C was great
PXL_20240413_141701861.jpg

1000037828.jpg
 
Last edited:

Nbrac27

Active Member
Established Member
Joined
Apr 5, 2018
Messages
136
Location
Fort Bragg, NC
1000038597.jpg

It's been a bit but just got back from a 5 week course down in Alabama and finally home and taking the Cobra out and about. Picture from the local C&C yesterday.

Still no cooling issues so at this point I'm going to say (knock on wood) the problem has been resolved.

Now onto what's going to happen next. I'm aiming to get it onto the dyno at one of my local shops to see what she's actually putting down, and then go from there!
 

Nbrac27

Active Member
Established Member
Joined
Apr 5, 2018
Messages
136
Location
Fort Bragg, NC
1000038863.jpg

Got the AeroFlowDynamics side skirt lips installed yesterday (pics coming soon) and now doing my new Kenwood headunit and kicker speakers.

Ran into a snag though, got the HU installed and before touching the speakers, tested it out and the only speaker getting power seems to be the back left one. The harness was wired by Crutchfield, and they've never messed up before for me, but I have no idea why there is only sound coming from one single speaker.

Has anyone else had something like this happen before?
 

Nbrac27

Active Member
Established Member
Joined
Apr 5, 2018
Messages
136
Location
Fort Bragg, NC
Well I have my car set as a 2004 and that's the harness it added automatically so I would assume as much?

I'm gonna have to reach out to them and ask to see, maybe that's the issue.
 

Nbrac27

Active Member
Established Member
Joined
Apr 5, 2018
Messages
136
Location
Fort Bragg, NC
Alright so I checked and have the correct harness, was just testing to see if power was going to each speaker while on the phone with Crutchfield and now only the front right speaker was working, and then when I moved the HU to test another wire, the whole thing shut off.

No fuses blown, everything else in the car was on fine, but the HU shut off.

So now theyre sending me a new harness to see if that is the issue, and then I guess will be going from there.

So for now, on a side note, here's some photos taken from one of the photographers walking around at the last C&C.

1000038858.jpg

1000038864.jpg

1000038857.jpg

1000038856.jpg
 
Last edited:

LS WUT

Well-Known Member
Established Member
Joined
Jun 26, 2013
Messages
4,260
Location
Sarasota, Florida
Alright so I checked and have the correct harness, was just testing to see if power was going to each speaker while on the phone with Crutchfield and now only the front right left speaker was working, and then when I moved the HU to test another wire, the whole thing shut off.

No fuses blown, everything else in the car was on fine, but the HU shut off.

So now theyre sending me a new harness to see if that is the issue, and then I guess will be going from there.

So for now, on a side note, here's some photos taken from one of the photographers walking around at the last C&C.

View attachment 1845704
View attachment 1845705
View attachment 1845706
View attachment 1845707
I’m not even a huge yellow fan, but god damn brother… that car hits harder than a step Dad on a Sunday. Beautiful cobra brother.
 

Nbrac27

Active Member
Established Member
Joined
Apr 5, 2018
Messages
136
Location
Fort Bragg, NC
The windows were actually tinted damn near 1% when I bought it (really they were 5.. but it seemed darker lol)

But between how loud the car is both actually, and visually, I didn't want to attract even more attention out here in NC than I already was with tinted windows that aren't legal. And it makes getting the car registered a huge pain in the ass if you don't know people
 

cj428mach

Well-Known Member
Established Member
Joined
Sep 21, 2012
Messages
7,637
Location
Kansas
I’m not even a huge yellow fan, but god damn brother… that car hits harder than a step Dad on a Sunday. Beautiful cobra brother.

You didn't know screaming yellow is the best color?

I really, really wish I would have gotten one over white. They look amazing with stock chrome wheels and they only come with the dark interior.
 

Nbrac27

Active Member
Established Member
Joined
Apr 5, 2018
Messages
136
Location
Fort Bragg, NC
I honestly kind of want to look into a set of chrome AFS wheels for that chrome on SY look because it does look amazing.

But I love the CCWs as well lol
 

cj428mach

Well-Known Member
Established Member
Joined
Sep 21, 2012
Messages
7,637
Location
Kansas
I honestly kind of want to look into a set of chrome AFS wheels for that chrome on SY look because it does look amazing.

But I love the CCWs as well lol

Black wheels always just look like black circle to me on cars. It doesn't matter what the pattern is, they might as well be some mid 90's Camaro salad shooters or 80's fox body turbine wheels painted black because honestly they all look the same. There was a guy trying to sell a low mileage SY with chrome 03's on it they may have been 18" reps I don't remember. I actually pondered the idea of selling my car for his but his had been pieced together from a low mileage roller. I'm glad though if not I'd probably have been looking into selling mine and buying his.......This was his car. I'm hard as diamonds after looking at it. SY is the best terminator color.
8671-dd87-2289-4-f35-9239-2-c83-dcd0-db32-jpg.1717008
72-b4-ab7-e-9-a1-d-4-bbd-9-e95-ed5660-d0749-d-jpg.1717010
 

LS WUT

Well-Known Member
Established Member
Joined
Jun 26, 2013
Messages
4,260
Location
Sarasota, Florida
You didn't know screaming yellow is the best color?

I really, really wish I would have gotten one over white. They look amazing with stock chrome wheels and they only come with the dark interior.
I feel that on a spiritual level. I have an OW Coupe. It’s not that I don’t like it. It’s just not my first choice, we will see how I feel when I get the new rims on it.
 

cj428mach

Well-Known Member
Established Member
Joined
Sep 21, 2012
Messages
7,637
Location
Kansas
I feel that on a spiritual level. I have an OW Coupe. It’s not that I don’t like it. It’s just not my first choice, we will see how I feel when I get the new rims on it.
I think a Terminator should be a eye popping color because when modded they are quite the ass kicker. So SY, SB, and TR are all great Terminator colors.....I left off mystic chrome because its just not my thing but it definitely fits Terminators.
 

Users who are viewing this thread



Top