• Welcome to SVTPerformance!

No spark 95 gt 5.0

Discussion in 'SN-95 and New Edge Mustangs' started by Sn95steve, Nov 3, 2018.

  1. Sn95steve

    Sn95steve New Member

    Messages:
    3
    Joined:
    Feb 17, 2018
    Location:
    Freehold Nj
    Hey guys I just got this 95 GT in addition to my 98 Cobra. New to the 5 liter Realm. The car sat for about a year. After jump starting the car and ran and then died out. We're not getting any Spark. I've already replaced the ignition coil, ignition module, distributor, cap and rotor, and also tried a different ignition switch. I didn't like the way the switch function so I changed it back to the original. I've gone through all the tests in the Haynes manual. Checking resistance and voltage. I have consistent voltage going into the primary wires of the coil from what the battery is putting out. But I cannot get the coil to generate a spark to the distributor cap. I've done all the continuity test on the ignition switch ignition module ignition coil and spout (little black plastic plug near ignition module) I also have 12 volts at the fuel injector harnesses. I've swapped in and out all the various new and old parts with no change. What else should I be testing? Why do I have power to the ignition coil but can't get any spark out I get power out of the ignition coil nipple where the wire goes from the coil to the distributor cap but does not generate Spark. What is my problem? You guys have been absolutely wonderful and see what you guys can do with a 5.0. I'm No rookie under the hood so don't be afraid to get technical. I've literally tried everything I can think of. Thanks in advance

    Sent from my SM-G960U using the svtperformance.com mobile app
     
  2. Sluggie24

    Sluggie24 Active Member Established Member

    Messages:
    255
    Joined:
    Jan 12, 2017
    Have you checked for a pulse signal coming out of the pickup in the distributor? If that isn't working the coil won't fire and the injectors won't pulse. You would need to use a scope to properly check for that waveform. Have you already checked the injectors with a noid light to see if they are getting pluse signals?
     
  3. Sn95steve

    Sn95steve New Member

    Messages:
    3
    Joined:
    Feb 17, 2018
    Location:
    Freehold Nj
    Tried 2 different distributors

    Sent from my SM-G960U using the svtperformance.com mobile app
     
  4. Nick Aaron

    Nick Aaron New Member Established Member

    Messages:
    19
    Joined:
    May 12, 2018
    Location:
    USA
    .
     
    Last edited: Nov 10, 2018

Share This Page