• Welcome to SVTPerformance!

Popping in front suspension

Discussion in 'New Edge Cobras' started by 01SVTSnake, Feb 3, 2009.

  1. 01SVTSnake

    01SVTSnake Thud Thud Thud Thud Thud Established Member

    Messages:
    6,227
    Joined:
    Mar 11, 2007
    Location:
    SE PA
    Recently, i did some front suspension work on my car (Bilsten struts, MM C/C Plates, Steeda X2 Balljoints, and Steeda Bumpsteer). I had the car aligned and it drives and handles great, but when turning (Mostly when the wheel is locked one way or the other) the front suspension has a popping to it. It feels like the whole car actually jumps a tiny bit. I notice it especially when backing up.

    I looked over my suspension tonight and didn't see any loose odds and ends. Anyone have any suggestions? I will try and get a video of the noise/shifts as soon as the weather improves (5+ inches of snow today)
     
  2. BreBar21

    BreBar21 Born in the G-Code Established Member

    Messages:
    8,895
    Joined:
    Feb 2, 2003
    Location:
    Orlando
    I assume you did all the simple stuff like greasing the ball joints and checking the spacers on the MM c/c plates, right?
     
  3. 01SVTSnake

    01SVTSnake Thud Thud Thud Thud Thud Established Member

    Messages:
    6,227
    Joined:
    Mar 11, 2007
    Location:
    SE PA
    Yeah, ball joints were greased and everything was triple checked when we installed it all. I did take it for alignment 2 days later and after thats when i first noticed the popping, but i didnt really lock the wheel one way the night the install was finished
     
  4. gmsux

    gmsux Denial ain't just a river Established Member

    Messages:
    1,779
    Joined:
    Sep 13, 2008
    Location:
    Vancouver, WA
    Double check the tie rods and CC plates for tightness first then check everything else. After this it's more diagnostic work to find what is making the noise.
     
  5. 01SVTSnake

    01SVTSnake Thud Thud Thud Thud Thud Established Member

    Messages:
    6,227
    Joined:
    Mar 11, 2007
    Location:
    SE PA
    Yeah, i'll do that in the morning. Does anyone happen to know what the specs are for the nut on top of the strut (something i want to check for piece of mind)
     
  6. Predatorbird

    Predatorbird Active Member Established Member

    Messages:
    3,139
    Joined:
    Jun 22, 2007
    Location:
    Florida
    My driver side does the same thing. It's coming from either the c/c plate or the strut. I have yet to figure out exactly what's causing the sound.
     
  7. Un4GivN

    Un4GivN QuenchMyThirstw/Gasoline Established Member

    Messages:
    4,060
    Joined:
    Nov 13, 2007
    Location:
    Concord, NC
    Mine does this while backing up as well.. Only I have stock struts and no CC plates.
     
  8. OzzDOA

    OzzDOA E-Green and Mean! Established Member

    Messages:
    733
    Joined:
    Jan 17, 2008
    Location:
    Philly
    I had this same problem and it turned out that the rubber rack bushings were shot.
     
  9. 01SVTSnake

    01SVTSnake Thud Thud Thud Thud Thud Established Member

    Messages:
    6,227
    Joined:
    Mar 11, 2007
    Location:
    SE PA
    Interesting on the rack comment. I noticed this right after the work was done, and we didnt touch the steering rack, but its something to look over
     
  10. fourvalvegt

    fourvalvegt New Member Established Member

    Messages:
    791
    Joined:
    Nov 3, 2006
    Location:
    Scottsdale
    your bumpsteer is set incorrectly, ive seen it happen a few times before and it did the exact thing you were describing
     
  11. OzzDOA

    OzzDOA E-Green and Mean! Established Member

    Messages:
    733
    Joined:
    Jan 17, 2008
    Location:
    Philly
    Well the stuff you did does alter the suspension geometry somewhat. What was happening in my case was after the car was lowered and aligned at full-lock the rubber rack bushings would bind up and then "thunk" back into place. I found this by putting the car on ramps and looked at everything while someone else turned the wheel lock to lock. I shot some lithium grease onto the bushings and that stopped it until I was able to install the offset poly ones.

    But like above stated it could also be a bumpsteer issue if the tie rod ends are getting all bound up due to their altered geometry. Its just one of those little quirks you get with lowering the front suspension of these cars.
     
  12. 1999 SVT Cobra

    1999 SVT Cobra New Member Established Member

    Messages:
    163
    Joined:
    Jul 15, 2008
    Location:
    Greenwood, MO
    I had the same problem when my car had stock suspension now I have x2 ball joints, bumpsteer, bilsteins, and mm cc plates, lowered with cut 04 springs and I still have it. Its more like the car is skidding across the pavement like your wheel turned so much while going backwards is skids a little across the ground. Im interested in seeing what this ends up being if its rack bushings I need them badly!!
     
  13. 01SVTSnake

    01SVTSnake Thud Thud Thud Thud Thud Established Member

    Messages:
    6,227
    Joined:
    Mar 11, 2007
    Location:
    SE PA
    Exactly. Hopefully i can get a better look at my suspension tomorrow.

    I'll take some pictures with the wheels off with the wheel maxed out in each direction and see if anyone sees anything abnormal
     
  14. 1999 SVT Cobra

    1999 SVT Cobra New Member Established Member

    Messages:
    163
    Joined:
    Jul 15, 2008
    Location:
    Greenwood, MO
    Any progress on an answer for this? haha mine still does it. I thought at first it might be my tires but I checked them and they are stock 245s so I know its not because they are too wide so idk. I think it might be the rack bushings like suggested above. Still interested in an answer. Keep me posted.
     
  15. 01SVTSnake

    01SVTSnake Thud Thud Thud Thud Thud Established Member

    Messages:
    6,227
    Joined:
    Mar 11, 2007
    Location:
    SE PA
    today was quite busy for me and so is tomorrow, but hopefully tomorrow night or saturday morning i will get some pictures up
     
  16. 01SVTSnake

    01SVTSnake Thud Thud Thud Thud Thud Established Member

    Messages:
    6,227
    Joined:
    Mar 11, 2007
    Location:
    SE PA
    I got just my air compressor back up and running. so hopefully some pics tonight
     
  17. 01cobradude

    01cobradude New Member Established Member

    Messages:
    28
    Joined:
    Oct 21, 2007
    Location:
    Maryland
    I get the popping noise also. Only in reverse on sharp turn. Stock supension now. Was previously lowered. 265/35-18 tires on front. Does not make noise while steering. Only when rolling backwards. Could it be too much toe-in? It would be nice to find solution.
     
  18. b dub

    b dub 4.10's or 4.30's??!! Established Member

    Messages:
    3,280
    Joined:
    Apr 13, 2005
    Location:
    Twentynine Palms
    I have this too, and I ordered aluminum rack bushings Friday. I'll let you know:)
     
  19. b dub

    b dub 4.10's or 4.30's??!! Established Member

    Messages:
    3,280
    Joined:
    Apr 13, 2005
    Location:
    Twentynine Palms
    Didn't forget about this. Got the MM bushings Friday, will be installing tomorrow.


    Then, report!
     
  20. kcpgt2002

    kcpgt2002 Member Established Member

    Messages:
    325
    Joined:
    Feb 26, 2007
    Location:
    Cedar Rapids, IA
    I just had a lower ball joint fail at 60k. They might be on there way out because mine was popping in reverse for along time until it completely popped out last night.
     

Share This Page