• Welcome to SVTPerformance!

Problem diagnosing help

Discussion in 'SN95 Cobras' started by v8musclecobra, Aug 4, 2019.

  1. v8musclecobra

    v8musclecobra Member Established Member

    Messages:
    807
    Joined:
    Sep 24, 2005
    Location:
    BOSTON, MASS
    having a hard time finding what’s going on with my 97 cobra and looking for help. The main problem with the car is if i start in too low a gear, the car will buck on and off uncontrollably. Under a correct gear it’s not as bad and as the rpm rises it gets better. Only happens under load ( so it’s worse up hill ). Briefly looked at the u joint and they look fine at least on the surface ( first thought it was a driveshaft). Motor mounts are good. Transmission mount is brand new. Plugs are new, fuel injectors are new, fuel filter is new, no codes are thrown. Clutch is spec 2+ which was replaced several years ago but don’t notice any slipping. Any ideas of what it could be or any questions i could answer to help narrow down the problem?
     
  2. J.Rovirosa

    J.Rovirosa Member Established Member

    Messages:
    590
    Joined:
    Sep 16, 2008
    Location:
    Socal
    The last time I had a similar issue, it turned out to be the coil packs. The problem would manifest itself when giving the car gas in fifth at highway speeds.
     
  3. Tillerman77

    Tillerman77 Active Member Established Member

    Messages:
    270
    Joined:
    Aug 28, 2016
    Location:
    Minnesota
    Monitor the RPM range where this happens to see if it is consistent or not.
     
  4. v8musclecobra

    v8musclecobra Member Established Member

    Messages:
    807
    Joined:
    Sep 24, 2005
    Location:
    BOSTON, MASS
    I feel like it slowly got worse over a week or so period. Monitor the rpms throughout each gear? From what i see it happens the worst around 1-1200rpm and gets better to near gone as the rpm increases. The rpm doesnt shoot up at wot like i saw when the clutch was bad which makes me think it’s not the clutch.
     
  5. Tillerman77

    Tillerman77 Active Member Established Member

    Messages:
    270
    Joined:
    Aug 28, 2016
    Location:
    Minnesota
    Does the engine do anything unusual (i.e. does it sound normal) if you rev it up from idle when in neutral?
     
  6. v8musclecobra

    v8musclecobra Member Established Member

    Messages:
    807
    Joined:
    Sep 24, 2005
    Location:
    BOSTON, MASS
    Motor sounds fine in neutral. No vibrations at any rpm that ive noted.
     
  7. v8musclecobra

    v8musclecobra Member Established Member

    Messages:
    807
    Joined:
    Sep 24, 2005
    Location:
    BOSTON, MASS
    New key...it seems to be fine in reverse; only in the forward gears is there noise/ hesitation. Could it be the 10 spline input shaft or would that also hesitate in reverse?
     
  8. Tillerman77

    Tillerman77 Active Member Established Member

    Messages:
    270
    Joined:
    Aug 28, 2016
    Location:
    Minnesota
    Maybe check with a shop that has experience with T-45 rebuilding and see what they have to say.
     

Share This Page