• Welcome to SVTPerformance!
ATTENTION!
You may experience intermittent issues while accessing the site over the next 60-90 minutes, as we perform maintenance and upgrades.

Quick question about h/e,intercooler and pump

Discussion in '2nd Generation' started by blacknite51, May 12, 2010.

  1. blacknite51

    blacknite51 New Member Established Member

    Messages:
    101
    Joined:
    Jun 1, 2008
    Location:
    Wisconsin
    So im getting my motor back together finally and i was wondering if i could run my truck without coolant in the intercooler system? I would disconnect the electrical on the pump. I am wondering this because i am waiting for my intercooler tank from True forged and and i want to see how the truck runs. I wont be boosting or beating on it because i have to break the motor in anyway and get a retune. and i cant run my stock tank because i sold it. any help would be great. thanks guys
     
  2. 01whiteL

    01whiteL New Member Established Member

    Messages:
    713
    Joined:
    Sep 20, 2006
    Location:
    Tomball,Tx
    keep it parked...
     
  3. FlaHP

    FlaHP New Member Established Member

    Messages:
    647
    Joined:
    Feb 1, 2006
    Location:
    Gainesville, Florida
    Your charge temps will go through the roof after a few minutes.

    If you want to start it up you can but don't run it too long
     
  4. SID297

    SID297 OWNER/ADMIN Staff Member Administrator

    Messages:
    51,450
    Joined:
    Mar 27, 2003
    Location:
    Myrtle Beach, SC
    I'd only start it up if I had to move it around. Any boost at all will be bad.
     

Share This Page