• Welcome to SVTPerformance!

Rear end rattle

Discussion in 'Driveline' started by Bdubbs, May 24, 2019.

  1. Bdubbs

    Bdubbs u even lift bro? Established Member

    Messages:
    13,120
    Joined:
    Jan 8, 2010
    Location:
    MN
    Hey guys,

    Need some insight. Car is a 90 notch with a 04 cobra irs. Just bought the car and was aware of the noise prior to buying.

    It's not really a "clunk" but more so a "rattle". Happens while driving normal, just cruising.

    I want to re-torque every nut and bolt. Should I have the car on Jack stands or ramps?

    I think I may also install 9/16 or 14mm subframe bolts.

    Anything else I should look for?

    Thanks.

    Sent from my Moto E (4) Plus using the svtperformance.com mobile app
     
  2. slo984now

    slo984now AKA 01yellerCobra Established Member

    Messages:
    14,901
    Joined:
    Oct 5, 2005
    Location:
    San Diego
    Usually a loose bolt causes a clunk. I would make sure the exhaust isn't touching and that the brake dust shields are tight. As for ramps or stands, that depends on the control arm bushings. If they're delrin or poly you can torque them with the suspension hanging. If they're original rubber I would load the suspension. The cradle bolts won't matter as they don't move once torqued.
     
    Bdubbs likes this.
  3. Bdubbs

    Bdubbs u even lift bro? Established Member

    Messages:
    13,120
    Joined:
    Jan 8, 2010
    Location:
    MN
    It's sounds more like a rattle or tapping. I believe all bushings are original, but I'll have to look more closely. I figured first I'd put on jack stands, then I can check brake components too. I've even heard bad shocks can make noise.

    Sent from my Moto E (4) Plus using the svtperformance.com mobile app
     
    slo984now likes this.
  4. slo984now

    slo984now AKA 01yellerCobra Established Member

    Messages:
    14,901
    Joined:
    Oct 5, 2005
    Location:
    San Diego
    Yeah. I've seen worn out shocks cause clunks and such.
     
    Bdubbs likes this.
  5. Bdubbs

    Bdubbs u even lift bro? Established Member

    Messages:
    13,120
    Joined:
    Jan 8, 2010
    Location:
    MN
    I tighten down a few odds and ends, nothing with the suspension though. Noise still present. Definitely thinking it's rear suspension.

    Sent from my Moto E (4) Plus using the svtperformance.com mobile app
     
  6. Bdubbs

    Bdubbs u even lift bro? Established Member

    Messages:
    13,120
    Joined:
    Jan 8, 2010
    Location:
    MN
    Well my looks like my passenger side sway bar end link is shot. Hope this is it. Can I go oem or should I get maximum motorsports?

    Heck I have the stock ones on the cobra still.

    Sent from my Moto E (4) Plus using the svtperformance.com mobile app
     
  7. BLOWN9646

    BLOWN9646 E85 COBRA Established Member

    Messages:
    1,995
    Joined:
    Apr 12, 2006
    Location:
    N IL
    Check the lower shock bolts are tight too
     
    Bdubbs likes this.
  8. Bdubbs

    Bdubbs u even lift bro? Established Member

    Messages:
    13,120
    Joined:
    Jan 8, 2010
    Location:
    MN
    Thanks I'll check it out. Ordering some oem style end links

    Sent from my Moto E (4) Plus using the svtperformance.com mobile app
     
  9. BLOWN9646

    BLOWN9646 E85 COBRA Established Member

    Messages:
    1,995
    Joined:
    Apr 12, 2006
    Location:
    N IL
    Np, thought it's worth a shot bc I made this mistake before replacing a Mazda shock and it had a constant rattle like you're describing
     
  10. Bdubbs

    Bdubbs u even lift bro? Established Member

    Messages:
    13,120
    Joined:
    Jan 8, 2010
    Location:
    MN
    I wonder what the torque spec is. I'll have to check.

    Sent from my Moto E (4) Plus using the svtperformance.com mobile app
     
  11. BLOWN9646

    BLOWN9646 E85 COBRA Established Member

    Messages:
    1,995
    Joined:
    Apr 12, 2006
    Location:
    N IL
    98ft-lb per MM install instructions
     
  12. Bdubbs

    Bdubbs u even lift bro? Established Member

    Messages:
    13,120
    Joined:
    Jan 8, 2010
    Location:
    MN
    They were tight.

    Sent from my Moto E (4) Plus using the svtperformance.com mobile app
     
    BLOWN9646 likes this.
  13. Bdubbs

    Bdubbs u even lift bro? Established Member

    Messages:
    13,120
    Joined:
    Jan 8, 2010
    Location:
    MN
    Here is the passenger side rear sway bar link. I'm not sure what kind of noise a bad one can make? But ordered a new set. I talked to the owner that did most of the work and he said it always made noise since the IRS went in. I still think it might be the front diff bushings.


    IMG_20190528_100839667_zps9zwbaipi.jpg


    IMG_20190528_101002113_zpsjmyrilrc.jpg


    Sent from my Moto E (4) Plus using the svtperformance.com mobile app
     
  14. 311-420

    311-420 Unknown Member Established Member

    Messages:
    2,140
    Joined:
    Apr 26, 2008
    Location:
    Universal
    I've had a clamp on my magnaflow catback come loose allowing the pipe to hit up against the frame rail and rattle. May be worth a check while you're under it.

    Edit- i see you've got an irs. Nm. The pipes don't go up and over the rear end housing like sra.
     
  15. Bdubbs

    Bdubbs u even lift bro? Established Member

    Messages:
    13,120
    Joined:
    Jan 8, 2010
    Location:
    MN
    The only place I have a clamp is at the muffler, but I'll check. The rest back is welded. I still think it might be the end link.

    Sent from my Moto E (4) Plus using the svtperformance.com mobile app
     
  16. 311-420

    311-420 Unknown Member Established Member

    Messages:
    2,140
    Joined:
    Apr 26, 2008
    Location:
    Universal
    Strap a go pro under there and drive around? This may reveal something..
     
    Bdubbs likes this.
  17. Bdubbs

    Bdubbs u even lift bro? Established Member

    Messages:
    13,120
    Joined:
    Jan 8, 2010
    Location:
    MN
    *Jay* and UncleSAm like this.

Share This Page