• Welcome to SVTPerformance!

Stock 03/04 Clutch life ?

Discussion in 'Driveline' started by 03soniccobra01, Jun 26, 2004.

How many miles have you got out of your 03/04 Cobra clutches?

  1. 0-10000

    95 vote(s)
    20.4%
  2. 10000-12500

    41 vote(s)
    8.8%
  3. 12500-25000

    141 vote(s)
    30.3%
  4. 25000-35000

    188 vote(s)
    40.4%
Thread Status:
Not open for further replies.
  1. HawkMech

    HawkMech Wildhorses Rule!!! Established Member

    Messages:
    222
    Joined:
    Dec 19, 2004
    Location:
    Clarksville, TN
    I'm just shy of 32,000 on my stock clutch now, and I've been running it had on the track since I got the car. This whole last year, all track passes have been made on 26x10.5 ET Streets, and the clutch is just starting to slip a little now. It only slips in 1st gear at the track with the ET Streets though. No problems at all on the street tires yet.
     
  2. Screamin Cobra

    Screamin Cobra Slam'd Cam'd Z06 Established Member

    Messages:
    8,140
    Joined:
    Oct 31, 2005
    Location:
    Baton Rouge, LA Vehicle: SRT10 Viper
    :shrug: Not too sure with 6K miles but i know that SOME 03's had some clutch problems outta the factory...
     
  3. B-O-B'03

    B-O-B'03 Active Member Established Member

    Messages:
    1,833
    Joined:
    Jun 14, 2002
    Location:
    TX
    Just got my car back on Friday, third Clutch PP and TOB, 26 K miles 38 months old.

    They replaced tranny with the second clutch.

    I don't baby the car but I don't rag on it either.

    This time they installed the "improved" reatiner sleeve.

    We'll see...

    -Brian
     
  4. TTA89

    TTA89 Member Established Member

    Messages:
    842
    Joined:
    Apr 1, 2003
    Location:
    Windham, NH
    16K miles and still on the stock clutch.
     
  5. Steeda30

    Steeda30 Clearance Clarence Established Member

    Messages:
    3,537
    Joined:
    Dec 10, 2004
    Location:
    Houston, TX
    40,300 miles on mine, pullied since ~5k. Daily driver and sees WOT often, but no powershifts/launches. :-D
     
  6. 96stanggt

    96stanggt Blower Whine Junkie Established Member

    Messages:
    9,275
    Joined:
    Sep 25, 2004
    Location:
    Charleston, SC
    UPDATE: Well the clutch let go yesterday......:D I've had the blower ported now for about 2K miles and put another 30 track passes on the clutch and the clutch had enough yesterday. I took a buddy with me down a road out in the sticks so he could film me doing a 1st-4th run and as I shifted to fourth the car went straight to redline. I thought I missed a gear but as I grabed the shifter I realized the car was in 4th!!!!!! :lol: It just let go....I guess it was too hot. I got on it in 2nd and 3rd later that night and it held but it still needs to be replaced...
     
  7. cobra04972tx1

    cobra04972tx1 HP, U CAN'T HAVE 2 MUCH Established Member

    Messages:
    1,220
    Joined:
    May 21, 2004
    Location:
    Little Elm,TX
    Mine has been disengaging funny since Ford changed my tranny. Almost feels like it isn't adjusted. I have gone through the adjustment, seems a bit better, but still when I shift at higher RPMs,around 5K and up, when I depress the pedal, I cant get the stick out into neutral so I can make a change, and when it does come out, it certainly doesn't feel like it has fully disengaged the flywheel. Any thoughts?
     
  8. mustang196718

    mustang196718 Snake#796,The Rice Killer Established Member

    Messages:
    747
    Joined:
    Oct 14, 2004
    Location:
    Ft. Wayne, IN
    Mine only lasted 8500 miles. Disc was down to the rivets and the flywheel had some grooves cut in it. Got so damn hot, it even heatspotted the input shaft. Guess that's what happens when you don't have time to rip it out and fix it, and by the time I actually got to it, it was toast.
     
  9. Steeda30

    Steeda30 Clearance Clarence Established Member

    Messages:
    3,537
    Joined:
    Dec 10, 2004
    Location:
    Houston, TX
    43,800 miles on mine now. 3,200 miles since the ported blower swap. Pullied since 5k. :-D
     
  10. CPViolation

    CPViolation Car Crazy Established Member

    Messages:
    5,194
    Joined:
    Mar 30, 2005
    Location:
    Gilbert, AZ.
    18k clutch is ok, the TB sounds like a bird in flight.
     
  11. Moody03SVT

    Moody03SVT [email protected] Established Member

    Messages:
    707
    Joined:
    Nov 5, 2004
    Location:
    Holly Springs
    23k now and TOB sounds sings once and a while
     
  12. Black01Stang

    Black01Stang New Member Established Member

    Messages:
    432
    Joined:
    Sep 18, 2002
    Location:
    Carroll County Va
    44k and still on the stock clutch. I think she's ready to go within the next few months though.
     
  13. 04SNK390HP

    04SNK390HP I hate SHEEPLE Established Member

    Messages:
    1,709
    Joined:
    Jan 1, 2006
    Location:
    Vilseck, Germany
    53000 on stock, still hooks like new with DR's
     
  14. 2 SLOW

    2 SLOW Keepin' it real Established Member

    Messages:
    773
    Joined:
    Mar 16, 2006
    Location:
    Houston, TX

    your car put down 393 bone stock? :eek:

    I just got my 04 and doesn't feel quite as fast as my cam only ls1 but seeing your numbers really make me want to put it on the dyno!
     
  15. BadMoFo

    BadMoFo Get Some! Established Member

    Messages:
    2,050
    Joined:
    May 27, 2003
    Location:
    Havelock NC
    have 50,xxx miles on her now and went to the drag strip every week last year and already went this year and the clutch is just not starting to get that smell. kinda getting hard to put in gear to so I figure its almost time to get a new one. its a daily driver and weekly racer.
     
  16. cobra101

    cobra101 New Member Established Member

    Messages:
    821
    Joined:
    Nov 30, 2002
    Location:
    LOS ANGELES
    34k miles on stock clutch. It has started to shutter a bit in last couple thousand miles. It is not slipping and I am oging to drive awhile longer before I go aftermarket.

    Would i need this "NEW Updated TOB Sleeve assm" when i bring to a mechanic to do the clutch? Or will an aftermarket clutch have all that I would need?

    Ps. I had the tob squeal early, about 8k miles. Ford wouldn't fix it b/c they said it was fine and it didn't chirp for them. It eventually went away. A firewall and clutch quadrant can fix some of the tob squeal, I just havent got one yet. :-D
     
    Last edited: Apr 10, 2006
  17. tankerman1981

    tankerman1981 New Member Established Member

    Messages:
    2,525
    Joined:
    Jun 19, 2005
    Location:
    Baumholder, Germany
    well got bout7K on my new clutch and no problems yet.... hopefully stays that way for awhile...
     
  18. Lord Warlock

    Lord Warlock New Member Established Member

    Messages:
    479
    Joined:
    Dec 25, 2005
    Location:
    Jacksonville FL
    Have 24k on my stocker, still grips fine. Is everyone's factory clutch very stiff to depress? my clutch is by far the stiffest clutch I've ever had, even more so than my competition clutch in my turbo stealth. I've had 4 mustangs, all with v8s and none had a clutch this stiff.
     
  19. 69gt4speed

    69gt4speed Svt God of All Established Member

    Messages:
    2,370
    Joined:
    Jan 16, 2003
    Location:
    east central ia
    Yes it's stiff compared to almost any stock clutch I've tried out. I don't know the tech details but suspect a organic friction for easy let out off a dead stop made them use a high static pressure to hold for the pwr, yet keep cost down.
    Your turbo stealth clutch could have been carbon and metallic more costly and possibly grab more off a dead stop and since the friction is higher they could keep a low static pressure. The other reason could be if hydraulic it could have a higher force multiplication whereas the cobra and older stangs use a cable and mech levers so to speak along with higher friction losses.
     
  20. 04CobraDean

    04CobraDean Banned

    Messages:
    137
    Joined:
    Apr 26, 2006
    Location:
    Oakland
    I have a 2004 Cobra, 5,300 miles and it chatters bad taking off from a dead stop in first gear. It sounds like I'm trying to take off in 3rd. I just bought this car. Has anyone else taken in their car for chatter and if so, what was it? Did the dealer fix it under warranty?
     
Thread Status:
Not open for further replies.

Share This Page