Stock throttle body on an Accufab style plenum? (Whipple 2.3L)

03 DSG Snake

Unknown Cyborg
Established Member
Joined
Nov 3, 2002
Messages
20,962
Location
CA
So had to return all the fuel and exhaust to stock on a 2.3L Whipple setup. It is the single blade made for an Accufab throttle which was on there previously.

Tried to run it with the stock throttle body last night and it idled and ran like crap. Came to realize the IAC slot in both the plenum and throttle body was way different. Swapped back to the Accufab and cured it right up.

Is there any way I can rig the stocker to function properly, either by tweaking the Idle screw, a remote IAC, or anything else? Definitely stuck with the current Whipple plenum and need to get the stocker on for testing.


Thanks!!




674A7866-B63C-418F-B263-FF595308C0E6.jpeg 8EA5C64D-D66E-4BAD-ADAD-ECCA574DEE74.jpeg
 

Black02GT

*Not 2KBlackGT
Established Member
Joined
Dec 12, 2004
Messages
5,471
Location
NY
So had to return all the fuel and exhaust to stock on a 2.3L Whipple setup. It is the single blade made for an Accufab throttle which was on there previously.

Tried to run it with the stock throttle body last night and it idled and ran like crap. Came to realize the IAC slot in both the plenum and throttle body was way different. Swapped back to the Accufab and cured it right up.

Is there any way I can rig the stocker to function properly, either by tweaking the Idle screw, a remote IAC, or anything else? Definitely stuck with the current Whipple plenum and need to get the stocker on for testing.


Thanks!!




View attachment 1671456 View attachment 1671455

Don't think so, you already caught the problem. The IAC passages don't line up so you'll never have a IAC as far as I can figure. I would think remote IAC might work but honestly to "function properly" for testing you'll need the matching TB. Just my .02.
 

03 DSG Snake

Unknown Cyborg
Established Member
Joined
Nov 3, 2002
Messages
20,962
Location
CA
Don't think so, you already caught the problem. The IAC passages don't line up so you'll never have a IAC as far as I can figure. I would think remote IAC might work but honestly to "function properly" for testing you'll need the matching TB. Just my .02.

Talked to James at Cobra Engineering (I run his IC kit) and remote IAC is the only likely solution. Will keep that in the pocket just in case the Accufab doesn’t squeak by.
 

Users who are viewing this thread



Top