• Welcome to SVTPerformance!
ATTENTION!
You may experience intermittent issues while accessing the site over the next 60-90 minutes, as we perform maintenance and upgrades.

T-45 Question and another one too..

Discussion in 'SN95 Cobras' started by CJsV8Bird, Nov 4, 2002.

  1. CJsV8Bird

    CJsV8Bird New Member

    Messages:
    294
    Joined:
    Mar 12, 2002
    Location:
    Houston
    I have a couple of ?'s for you guys. I'm not at all familiar w/ the DOHC engine yet, so you'll have to bear w/ me.

    Tranny ? first:

    I just bought a Mystic Cobra. I know the person I bought it off of, so I was familiar w/ how well it was taken care of, etc. Anyway, he put a pro 5.0 shifter in it. And it started popping out of 4th gear. You have to shift it just right to get it to stay. He thought that the shifter just needed adjusted, and ended up putting the stock one back in. But, when he did that, 4th gear still won't stick. Any ideas on what is causing that to happen? He thinks it's a linkage.

    Also, he has a C&L mass air meter. His car started making a really goofy noise every time it was started. He took in into Ford, and they said it had something to do w/ the secondary air intake being worn out due to the meter. Does that make sense? It cost him $500 bucks to fix. And they told him if he didn't go back to stock it'd wear out again. C&L claims that you don't have to tune the car after installation, but, would that take care of the problem. I guess they said that it wore out b/c the motor was taking in more air than the sensor "said" it was. But, I would think that would make the engine run lean and kick on a check engine light, which didn't happen. Any ideas on that one?

    I had another ?, but I forget what it was. I guess I'll have to come back when I remember it.

    Thanks-
     
  2. SVT X 2

    SVT X 2 I C U Established Member

    Messages:
    1,385
    Joined:
    Nov 21, 2000
    Location:
    Twin Cities
    I would check the linkage first on the tranny.

    As for the other problem... you'd have to explain "goofy noise" more thoroughly... but I'm wondering if they are talking about the IMRC plates? But always understood that to be a problem when the car is driving, so? I've never heard of a meter causing this to happen though... and I wouldn't take stock in what a dealer mechanic says all the time. Sometimes they look for the easiest & quickest answer (aftermarket parts) to blame a problem on.
     
  3. CJsV8Bird

    CJsV8Bird New Member

    Messages:
    294
    Joined:
    Mar 12, 2002
    Location:
    Houston
    Yeah, that's what I was thinking too. (not buying what the dealer said) That's why I was asking you guys about it. I've never heard of a MAF to cause any kind of problem that made a noise of any sort. But, I was also not familiar w/ Cobra's and the secondary intake deal they have. So, I don't know. It was a really strange....squeaking noise (not a belt-like noise)......hard to explain.....nothing to compare it too really....It happened every time the car was started, just after the rpm's come down from a cold start. I think she just needs a good dyno tune as far as that goes. It's been fixed by ford, cost my boss 500 bucks.

    The tranny?....I know a guy who's a Ford tech. who will rip apart a tranny and check it all out for $50 (on the side job). And see what the deal is. I was thinking it's either the linkage. Or the stop for 4th is incorrect. I'll have to investigate further, I guess.
     

Share This Page