• Welcome to SVTPerformance!

Title Issues

Discussion in 'Fox-Body Cobras' started by Blake 93, Oct 3, 2019.

  1. Blake 93

    Blake 93 New Member

    Messages:
    2
    Joined:
    Oct 2, 2019
    Location:
    TN
    I recently purchased a 93 Cobra, prior to acquiring the car I ran the VIN # on separate sites. The results from these sites all provided clean title results, now I find from CARFAX (thx for helping Zak with report) showing total loss? My title shows no salvage or rebuild, Carfax showed no structural damage or airbag deployment (all from 1995). I have inspected the car for indications of prior damage and only discovered a slight bubble on front frame rail. Car still retains stock radiator support and aprons but it has a ford OEM bumper cover installed. Rest of the car is stock with the exception of exhaust, seat covers and LMR quarter glass have replaced the original.

    I purchased the car knowing it needed restored which I still plan on completing. Has anyone else had this issue before? Could the car have been stolen at some point prior? My title like stated is clean with no brands? Guess I'm just ranting about finding this out but at the end of the day it's still a 93 Cobra which will be restored?
    This ever happen to anyone??
     
  2. jmsa540

    jmsa540 Well-Known Member Established Member

    Messages:
    2,828
    Joined:
    Dec 17, 2009
    Location:
    Fort Benning, GA
  3. buddha93

    buddha93 Active Member Established Member

    Messages:
    2,401
    Joined:
    Oct 31, 2002
    Location:
    St. Louis
    Could be a theft recovery car, different states have different laws as it pertains to car titles. While one state may show a salvage or rebuild title, it's simple matter of getting the title in another state as a way of gaining a clean one.

    It's also possible there is an error with Carfax, as these not every report is 100% accurate.
     

Share This Page