• Welcome to SVTPerformance!

1993 Mustang Cobra TPS Issue

Discussion in 'Fox Body Mustangs' started by Tbrake1978, Mar 8, 2020.

  1. 98 svt

    98 svt Well-Known Member Established Member

    Messages:
    17,493
    Joined:
    May 16, 2005
    Location:
    Nunya, MA
    Go to the local parts store and grab a new tps. They are under $50. If it doesnt fix the issue, return it.
    Certainly sounds like it's the culprit.
     
    Last edited: Mar 9, 2020
  2. Tbrake1978

    Tbrake1978 Member Established Member

    Messages:
    38
    Joined:
    Mar 6, 2020
    Location:
    Kansas
    Got one on order. Picking it up tomorrow. I will update tomorrow night
     
    98 svt likes this.
  3. RunninHorse

    RunninHorse Member Established Member

    Messages:
    64
    Joined:
    Feb 15, 2020
    Location:
    San Antonio, Texas
    An EEC failure can also cause constant 5vdc at the green TPS wire, but you'd have more than just a surging idle.

    Have there been any recent changes to the car? When did the surging idle start?

    It's worth running KOEO/KOER self tests. Even if the check engine light isn't on. See attachment.

    In general, a base idle reset should help with surging idle. See attachment. I'd run codes first though.

    Any tuner worth his salt should tell you not to try to tune it while there are any type of issues. Get everything fixed and all codes cleared first.
     

    Attached Files:

  4. Tbrake1978

    Tbrake1978 Member Established Member

    Messages:
    38
    Joined:
    Mar 6, 2020
    Location:
    Kansas
    Thanks for the info.
    No changes
    Its idle surged ever since the first day I got the car. I backed the timing to 10-11 degrees but that is the only adjustments I have recently made.
     
  5. buddha93

    buddha93 Well-Known Member Established Member

    Messages:
    2,440
    Joined:
    Oct 31, 2002
    Location:
    St. Louis
    Have you tried running the car with the MAF unplugged? Factory unit?
     
  6. Tbrake1978

    Tbrake1978 Member Established Member

    Messages:
    38
    Joined:
    Mar 6, 2020
    Location:
    Kansas
    I have not tried that
     
  7. 98 svt

    98 svt Well-Known Member Established Member

    Messages:
    17,493
    Joined:
    May 16, 2005
    Location:
    Nunya, MA
    Did you get the new TPS?
     
  8. Tbrake1978

    Tbrake1978 Member Established Member

    Messages:
    38
    Joined:
    Mar 6, 2020
    Location:
    Kansas
    Update:

    Replaced TPS- Was able to get my .98V reading

    Changed to a X3Z computer.
    Performed Base Idle reset
    Idle still surges a little bit
    1/4 Throttle seems like full throttle and doesnt return to idle right away
     
  9. Tbrake1978

    Tbrake1978 Member Established Member

    Messages:
    38
    Joined:
    Mar 6, 2020
    Location:
    Kansas
    Yes. I am getting the correct reading now. Still doesnt run right
     
    98 svt likes this.
  10. 98 svt

    98 svt Well-Known Member Established Member

    Messages:
    17,493
    Joined:
    May 16, 2005
    Location:
    Nunya, MA
    Good to hear its functioning correctly now. Possibly back to a vaccum leak. Did you try checking for leak with carb cleaner?
     
    Last edited: Mar 10, 2020
  11. Tbrake1978

    Tbrake1978 Member Established Member

    Messages:
    38
    Joined:
    Mar 6, 2020
    Location:
    Kansas
    I performed a smoke test on the system. No leaks to be found
     
  12. Tbrake1978

    Tbrake1978 Member Established Member

    Messages:
    38
    Joined:
    Mar 6, 2020
    Location:
    Kansas
    I did notice that I could get the idle to surge if I pinch one of the vacuum lines
     
  13. MG0h3

    MG0h3 Well-Known Member Premium Member Established Member

    Messages:
    6,854
    Joined:
    Jul 23, 2014
    Location:
    El Paso, TX
    Why did the switch the ECM?


    Sent from my iPhone using svtperformance.com
     
  14. RunninHorse

    RunninHorse Member Established Member

    Messages:
    64
    Joined:
    Feb 15, 2020
    Location:
    San Antonio, Texas
    If you have .98 vdc at closed throttle, your computer should register WOT at 3.69 vdc. (Closed throttle voltage plus 2.71). You could monitor the voltage as you open the throttle to see how soon you get there.

    I spent a little time tuning the X3Z in my coupe. I'm no expert, but I do remember there is something that controls how quickly it returns to idle. @decipha would be the best person to help you figure that out over at EFIDynoTuning.com.

    I loaded one of his base tunes on mine and my coupe ran much better. It was a night and day difference for me. Still kills me that I never got it back to the track after the initial tune changes.

    I used a QuarterHorse by Moates. 'QuarterHorse' for Fords [QH1] - $249.00 : Moates.Net
     
  15. Tbrake1978

    Tbrake1978 Member Established Member

    Messages:
    38
    Joined:
    Mar 6, 2020
    Location:
    Kansas
    I switched it because it is the X3Z computer that is specifically for a Cobra so I thought I would put it in there and see what happens.
     
    MG0h3 likes this.
  16. Tbrake1978

    Tbrake1978 Member Established Member

    Messages:
    38
    Joined:
    Mar 6, 2020
    Location:
    Kansas

    I bought an SCT Eliminator Chip and have a tune scheduled for this Thursday. The shop is supposed to be the best in the area. I am just hoping I can get it there and them figure it out
     
  17. MG0h3

    MG0h3 Well-Known Member Premium Member Established Member

    Messages:
    6,854
    Joined:
    Jul 23, 2014
    Location:
    El Paso, TX
    Man Ive been away from foxes ive forgotten a lot.

    So do you get a steady idle at the correct RPM and it surges once the IAC is plugged back in?


    Sent from my iPhone using svtperformance.com
     
  18. Tbrake1978

    Tbrake1978 Member Established Member

    Messages:
    38
    Joined:
    Mar 6, 2020
    Location:
    Kansas
    It usually surges for about a minute and then it will idle ok and then randomly starts to surge again
     
  19. decipha

    decipha Active Member Established Member

    Messages:
    729
    Joined:
    Jul 12, 2008
    Location:
    New Orleans, LA
  20. Tbrake1978

    Tbrake1978 Member Established Member

    Messages:
    38
    Joined:
    Mar 6, 2020
    Location:
    Kansas
    Once I put the X3Z computer in, set base idle, it runs really good now. Keep fingers crossed. I drive it 45 miles to Tune Shop... I will keep this post updated on how everything goes.
     

Share This Page