• Welcome to SVTPerformance!

bad stutter , lean af reading,,

Discussion in 'The Blower Bistro' started by Kennedy jay, Nov 16, 2019.

  1. Kennedy jay

    Kennedy jay Member Established Member

    Messages:
    32
    Joined:
    Jun 29, 2018
    Location:
    Louisville ky
    so, im running an eaton swap mach 1. vmp tuned, 4 pound pully, stock upper. cobra heads, lethal dual pump kit. 9.5 to 1 comp. factory maf. c and l intake.
    lately ive noticed a bad stutter if i hold throttle at,about 1500 rpm, it gets worse under load... really saw it on the dyno.. a/f gauge show lean when this happens. i did notice both fuses on the fuel pump relays were slightly heat damaged. replaced both. both pumps work, but if i remove 1 fuse the rpms of the remaining pump go up.. and the fpr is making a crazy ticking sound...
    i replaced the plugs,, checked all the coils.. cleaned the maf, nothing has helped the sputter, lean condition .
    any help or opinions appreciated..
     
  2. Kennedy jay

    Kennedy jay Member Established Member

    Messages:
    32
    Joined:
    Jun 29, 2018
    Location:
    Louisville ky
    fuel pumps are good, maf is reading ok, a/f wideband is jumping from 14.3 to 15.4 or so when its misfiring.. replaced plugs, checked and moved coils around with no change... not throwing a code.. maybe o2s?? anyone?
     
  3. blownstang4.6

    blownstang4.6 Active Member Established Member

    Messages:
    459
    Joined:
    Nov 8, 2011
    Location:
    Chicago
    14.3-15.4 is normal idle/cruising afr. Replace front 02's. If still doing it it's most likely the tune. Why a stock maf?
     
  4. Kennedy jay

    Kennedy jay Member Established Member

    Messages:
    32
    Joined:
    Jun 29, 2018
    Location:
    Louisville ky
    just havent upgraded yet,, only running 13 lbs of boost.. hasn't been a problem yet.. im changing o2s tommorow.
     
  5. 01yellercobra

    01yellercobra AKA slo984now Established Member

    Messages:
    16,503
    Joined:
    Oct 5, 2005
    Location:
    San Diego
    Rarely both O2's go bad together. Your tuner let the car go with this issue? Or did it start after the tune was done?
     
  6. Kennedy jay

    Kennedy jay Member Established Member

    Messages:
    32
    Joined:
    Jun 29, 2018
    Location:
    Louisville ky
    after, it was noticed on the dyno about a week ago..would a change in the lower pully from stock to metco 4lb make it run lean? didnt really notice it before. was making a log pull when we noticed it.. it starts being noticeable at about 1500 rpm. setting still. worse under load.
     

Share This Page