• Welcome to SVTPerformance!

Oil pressure on the highway

Discussion in 'SN-95 and New Edge Mustangs' started by Rolltide1006, Jan 12, 2019.

  1. Rolltide1006

    Rolltide1006 Member Established Member

    Messages:
    73
    Joined:
    Jun 8, 2018
    Location:
    Marietta, Ga
    Hello all and I apologize if this issue I am having has been answered before. I can’t find my particular issue discussed on google :( Oil is full and is Motorcraft 5w-20 with a Motorcraft oil filter. Wiring to the autometer gauge is

    I have a 97 GT and hooked up a autometer oil pressure gauge to know where I am at. The motor is a 4.6 2v and has PI heads, blower cams and was rebuilt 2k miles ago. Oil pressure is 70-80psi on cold start and I never lose it or see it drastically change. When nice and hot, I am idling with 20-25 psi. Once i bump the throttle it shoots to 50 psi. When I accelerate hard from a stop I see a nice gradual climb with pressure all the way to 60-70 psi. When I am driving on the highway is when I notice a slight fluctuation. When I am going 70-75mph in 5th gear at about 2200 rpm I noticed the meter was at 50 psi. I give it throttle and the needle will drop slightly down to about 45 psi and once I let off the throttle it will jump back to 50 psi. When I am at the same speeds and drop it into 3rd and accelerate the pressure goes to 55 and doesn’t climb as quick as it does when I am messing around in town. This is my first time having a aftermarket oil pressure gauge so I may be just a little paranoid. Just wanted to hear yalls opinions and/or experiences. Am I crazy or what? Thanks in advance!


    Sent from my iPhone using Tapatalk Pro
     
  2. Rolltide1006

    Rolltide1006 Member Established Member

    Messages:
    73
    Joined:
    Jun 8, 2018
    Location:
    Marietta, Ga
    Is this normal?


    Sent from my iPhone using Tapatalk Pro
     
  3. Weather Man

    Weather Man Persistance Is A Bitch Premium Member Established Member

    Messages:
    12,890
    Joined:
    May 18, 2012
    Location:
    MN
    Yes, normal.
     
    Rolltide1006 likes this.
  4. Rolltide1006

    Rolltide1006 Member Established Member

    Messages:
    73
    Joined:
    Jun 8, 2018
    Location:
    Marietta, Ga
    Oil pressure at idle dropped to 12.5 psi this morning after my commute to work. I changed the oil and filter on my lunch break fired it up, checked level and all is well. 30 min before work ended I fired the car up to let it get warm. Started to hear a subtle tap. Put it on the lift and was able to locate the area of the tap with my stethoscope. The tap is coming from around cylinders 7 and 8 down low. I can’t win with this motor right now. This is the 2nd rebuild within 2 years. Ive always used motorcraft oil and filters.


    Sent from my iPhone using Tapatalk Pro
     

Share This Page