2004 Escape P0443

03cobra#694

I Have LL’s Hammer
Super Moderator
Joined
Nov 12, 2003
Messages
57,512
Location
SW FL.
108K miles. Just popped up on my wives Escape. I cleared the code, came right back after a 2 mile run to the market.
Gas cap, or purge valve?
 

Crimson2v

Well-Known Member
Established Member
Joined
Apr 30, 2009
Messages
2,885
Location
North Carolina
Looks like a circuit code for the purge valve. I would check the wiring to it, many vermin enjoy nibbling on Evap components.
 

svtfocus2cobra

Opprimere, Velocitas, Violentia Operandi
Established Member
Joined
Sep 24, 2004
Messages
23,344
Location
Washington
Thanks, I'll look at it today. It was raining all day yesterday.

Tomorrow I can give you the most common repairs for that code when I get to work. Most of the time when I see that code the repair will be to replace the purge valve.
 

svtfocus2cobra

Opprimere, Velocitas, Violentia Operandi
Established Member
Joined
Sep 24, 2004
Messages
23,344
Location
Washington
Results are sort of all over the place but I would go with the purge solenoid first, but if that checks out then here are some other results to look at.
Screenshot_20200106-083706_Gallery.jpg
Screenshot_20200106-083805_Gallery.jpg
Screenshot_20200106-083833_Gallery.jpg
 

286rocks

Member
Established Member
Joined
Oct 15, 2010
Messages
116
Location
Kaneohe, HI
I had a similar code (it actually might have been the same) pop on a 4.0l ranger a few years ago. It was pointing to the purge valve being faulty.

I looked at buying a new one but there was no way in god damn hell I was spending $40 to keep a few penguins from melting. After taking the solenoid apart I found there was a Flyback Diode across a coil, which acts as an electromagnet to open and close the valve.

Of course it was burnt out, so I just scavenged another one from an old tube TV, soldered it on, and slapped the valve back together. Worked like a champ.

The diodes only job is to protect the PCM from small voltage spikes as the field collapses from being deenergized, however, if it's failing or failed then the valve can do some pretty screwball crap, or not work at all.
 

CobraBob

Authorized Vendor
Established Member
Premium Member
Single Barrel Sirs
Joined
Nov 17, 2002
Messages
102,790
Location
Cheshire, CT
Glad you found the source, Brad. And good that you updated the thread. That should help going forward if others encounter the same code.
 

nxhappy

Well-Known Member
Established Member
Joined
Dec 16, 2006
Messages
10,031
Location
AZ
Lol
I finally got around to it yesterday, and took maybe 10 minutes to put in.
those are the best jobs .... I just did a coolant temp sensor in a triton motor ....it's underneath the intake mani and makes we wanna slap the ford engineer
 

Users who are viewing this thread



Top