• Welcome to SVTPerformance!
ATTENTION!
You may experience intermittent issues while accessing the site over the next 60-90 minutes, as we perform maintenance and upgrades.

Those of you with Ethanol % Sensors

Discussion in 'The Distillery' started by cidsamuth, Feb 17, 2021.

  1. cidsamuth

    cidsamuth Liberty Biberty Established Member

    Messages:
    842
    Joined:
    Aug 16, 2010
    Location:
    Virginia
    So, not interested in debating whether the gas testing kits are better, as I've already installed the sensor. Just curious if what I'm seeing is normative.

    I have the Aeroforce sensor going to an analog input of my Interceptor. Right now, I'm not driving the car because of salt on the roads, and it has pump 93 (E10) in it.

    With the ignition "on," and the pump running (engine off), it is reading 11.6% steady. Fuel pressure (return style) is set to 48 lbs. I'm honestly not sure whether the E10 these days in my area tends to be even higher than 10%, or whether it's actually 10% and the 11.6 just represents sensor/gauge standard error.

    But what's most curious, when you start the motor and let the engine idle, the reading fluctuates between 10.5 and 11.2. Pressure is still at 48ish.

    While I realize it is normal for the reading to fluctuate like that +-1%, why would it be rock steady (and higher) when the engine isn't running and the pump pumping fuel at the same rate?
     
  2. DSG2003Mach1

    DSG2003Mach1 Premium Member Premium Member Established Member Single Barrel Sirs

    Messages:
    11,581
    Joined:
    Apr 15, 2004
    Location:
    Central Fl
    is your return system dead head and once the lines are pressurized it's not getting any flow across the sensor?
     
  3. 01yellercobra

    01yellercobra AKA slo984now Established Member

    Messages:
    17,542
    Joined:
    Oct 5, 2005
    Location:
    Cali
    My system is deadhead and I've noticed when sitting the percentage stays the same while KOEO. I've seen the percentage change one or two percent while driving, but that was usually after filling up and after getting a few miles down the road. I chalked it up to the fuel mixing while driving.
     
  4. cidsamuth

    cidsamuth Liberty Biberty Established Member

    Messages:
    842
    Joined:
    Aug 16, 2010
    Location:
    Virginia
    My system is return style.

    At this point, the only thing I can think of is that the firing of the injectors when the engine is running affects the readings
     
  5. biminiLX

    biminiLX never stock Premium Member Established Member

    Messages:
    11,119
    Joined:
    Jan 17, 2003
    Location:
    Toledo, OH
    4sdvenom likes this.
  6. 9397SVTs

    9397SVTs Well-Known Member Established Member

    Messages:
    917
    Joined:
    Oct 28, 2012
    Location:
    AZ
    I've got this in my car:
    2Q==(15).jpg
    Innovate DLG-1

    I have a return system and it does the same as you describe. KOEO-steady, KOER-fluctuates.
     
  7. cidsamuth

    cidsamuth Liberty Biberty Established Member

    Messages:
    842
    Joined:
    Aug 16, 2010
    Location:
    Virginia
    okay, that helps. Thanks!
     
  8. 96dreamer

    96dreamer Well-Known Member Established Member

    Messages:
    1,744
    Joined:
    Feb 22, 2007
    Location:
    St.Louis
    I'm running a 13577429 sensor in a 3d printed housing I got off ebay in my return line currently. Readings while running or KOEO are rock solid fluctuating ~.4% for a 10 minute log but at any particular time completely steady.

    I have the same housing @biminiLX posted and it looks like an extremely nice piece. I'm planning on running that on the supply line with the same sensor when I redo the fuel system here real soon.
     
  9. MG0h3

    MG0h3 Well-Known Member Established Member

    Messages:
    8,691
    Joined:
    Jul 23, 2014
    Location:
    El Paso, TX
    This is just a wideband no?

    I think these guys are talking about ethanol in their fuel


    Sent from my iPhone using the svtperformance.com mobile app
     
  10. biminiLX

    biminiLX never stock Premium Member Established Member

    Messages:
    11,119
    Joined:
    Jan 17, 2003
    Location:
    Toledo, OH
    I believe Innovate has a model that is also an Ethanol sensor and wideband O2 combo.
    He may have just linked the wrong pic?
    -J
     
  11. MG0h3

    MG0h3 Well-Known Member Established Member

    Messages:
    8,691
    Joined:
    Jul 23, 2014
    Location:
    El Paso, TX
    Ya I’ve never seen an ethanol sensor but it goes on the fuel line and those O2 sensors sure aren’t doing that


    Sent from my iPhone using the svtperformance.com mobile app
     
  12. biminiLX

    biminiLX never stock Premium Member Established Member

    Messages:
    11,119
    Joined:
    Jan 17, 2003
    Location:
    Toledo, OH
  13. 9397SVTs

    9397SVTs Well-Known Member Established Member

    Messages:
    917
    Joined:
    Oct 28, 2012
    Location:
    AZ
    Yeah.. I screwed up.. I've got the Innovate ECF-1 too. That's the one I was referring to.
     
    biminiLX likes this.

Share This Page