• Welcome to SVTPerformance!

Trouble with solving a very strang problem, any help?

Discussion in 'New Edge Cobras' started by nofxious, Sep 4, 2016.

  1. nofxious

    nofxious New Member Established Member

    Messages:
    9
    Joined:
    May 26, 2013
    Location:
    Chicago
    Hey friends, I have a 99 Cobra and recently, out of the blue, I've been getting a P1233 and P0602 codes popping on me. It's strange because it runs great, and completely randomly my idle goes to hell and I can't give the engine any gas with out it sputtering to death and EVERY TIME I know it's about to happen because my right blinker pop on very dimmly. After sputtering for about 5 minutes it the blinker pops off and it goes right back to normal.

    I've seen a few things about these codes, from PCM to Bad fuel pressure but I can't seem to solve it. I just changed the plugs and injectors hoping to get lucky, and it seemed to have worked for a few days but it just happened again tonight.

    Car has a CAI and a custom tune using an sct tuner. I've had the same tune for 3 years without any problem until just recently. Any ideas??
     
  2. 01yellercobra

    01yellercobra AKA slo984now Established Member

    Messages:
    17,162
    Joined:
    Oct 5, 2005
    Location:
    Cali
    P1233 points towards the FPDM. Which would make sense with you talking about the idle going to hell and not being able to accelerate. If you know someone locally try swapping FPDM's for a bit and see if the code comes back.
     
  3. CobraBob

    CobraBob Authorized Vendor Premium Member Established Member Single Barrel Sirs

    Messages:
    94,833
    Joined:
    Nov 17, 2002
    Location:
    Cheshire, CT
    It sounds like you have a bad FRPS (Fuel Rail Pressure Sensor). To test, pull the vacuum line off the FRPS and see if it smells like gas. If it does then your FRPS is probably bad.
     
  4. nofxious

    nofxious New Member Established Member

    Messages:
    9
    Joined:
    May 26, 2013
    Location:
    Chicago
    Would that problem be off and on? Sometimes it can run for days without screwing up, and then sometimes it will happen 2-3 times in a short drive. Also, would that explain why the blinker pops on half dim when the code pops?
     
  5. 01yellercobra

    01yellercobra AKA slo984now Established Member

    Messages:
    17,162
    Joined:
    Oct 5, 2005
    Location:
    Cali
    FRPS is usually a constant thing. At least in my experience. My car wouldn't even start when the FRPS blew. With the FPDM it could be fine and then get too hot or something and act up. It might be back feeding to the CCRM or something to cause your blinker like to pop on. That's why I suggested finding a buddy to swap with.
     
  6. RX1Cobra

    RX1Cobra Well-Known Member Established Member

    Messages:
    1,713
    Joined:
    Jul 2, 2012
    Location:
    IL
  7. nofxious

    nofxious New Member Established Member

    Messages:
    9
    Joined:
    May 26, 2013
    Location:
    Chicago
    Wow, this sounds like my exact problem. I did look at those grounds just the other day, looking for any sign of a loose contact and didn't notice anything out of place, but I'm going to remove them and make sure there's no corrsion build up now, or possibly a broken wire, the crappy thing is, the problem onl happens completely randomly so there's no way to force the error. I almost wish it would just stay broken so I know that i fixed it. ANy how, thank you so much for that info. I've looked for days in here searching those error codes and never came up with an answer. I'll report back and let you know how it goes
     

Share This Page