Code P03A1 - what is it?

5.0 Hatch

Well-Known Member
Established Member
Joined
Dec 21, 2005
Messages
698
Location
Gulf coast
Really appreciate the help here. Question, I'm not sure what vref is so I'll need to research that.

Forscan shows my frp v at .55v with key on engine off. 2.77v key on engine idle. Does this tell us anything??
 

Vinnie_B

"LIVE LIFE AT FULL THROTTLE"
Established Member
Premium Member
Joined
Jun 22, 2021
Messages
1,126
Location
Michigan
Really appreciate the help here. Question, I'm not sure what vref is so I'll need to research that.

Forscan shows my frp v at .55v with key on engine off. 2.77v key on engine idle. Does this tell us anything??
Battery voltage
*** KOEO Reference voltage should be around 3.3 VDC, HOT IDLE reference voltage should be around 2.8 VDC

VREF (Voltage Reference) is a 5 vdc voltage that comes from the PCM. VPWR/VBAT (Voltage Battery) is voltage from the battery.


You need to check for VREF as I described in post #15 @5.0 Hatch first. Than move on to the 02 sensors. That could be a whole seperate issue or caused by P0190


 
Last edited:

5.0 Hatch

Well-Known Member
Established Member
Joined
Dec 21, 2005
Messages
698
Location
Gulf coast
Tested 5v to the frps.

The o2's are brand new. Less than 20 miles. I see them switching on forscan so they're definitely doing something.
 

Vinnie_B

"LIVE LIFE AT FULL THROTTLE"
Established Member
Premium Member
Joined
Jun 22, 2021
Messages
1,126
Location
Michigan
Tested 5v to the frps.

The o2's are brand new. Less than 20 miles. I see them switching on forscan so they're definitely doing something.
OK. If 5 VREF is good @ FRP sensor. Sounds like 02's are working too. Next verify your FRPS is good. Once you verify lets us know.
 

5.0 Hatch

Well-Known Member
Established Member
Joined
Dec 21, 2005
Messages
698
Location
Gulf coast
Cleared all codes and drove it for a bit. The only code I'm getting now is p0172.

Others things I noted, fuel pressure drops to zero after about 20 seconds of turning off the car. The long crank times get shorter if I cycle the key a few times before starting. Next is I think I can smell gas in the oil.

I'm out of ideas.
 

Vinnie_B

"LIVE LIFE AT FULL THROTTLE"
Established Member
Premium Member
Joined
Jun 22, 2021
Messages
1,126
Location
Michigan
OK.

P0172 - System to Rich (Bank 1)

The Adaptive Fuel Strategy continuously monitors the fuel delivery hardware. The test fails when the adaptive fuel tables reach a lean calibrated limit.


Verify SHRTFT 1 and 2 PID value is between -25% to +35% and a LONGFT 1 and 2 PID value between -35% to +35% **** Reading beyond these values indicate a failure.

If your SHRTFT and LONGFT fuel trim values are out of value range check the following until you find the problem. Any one of these could be the cause:


  • Fuel system
  • Excessive fuel pressure.
  • Leaking/contaminated fuel injectors.
  • Leaking fuel pressure regulator.
  • Low fuel pressure or running out of fuel.
  • Vapor recovery system.
  • Induction system:
    • Air leaks after the MAF.
    • Vacuum Leaks.
    • PCV system.
    • Improperly seated engine oil dipstick.
  • EGR system:
    • Leaking gasket.
    • Stuck EGR valve.
    • Leaking diaphragm or EVR.
  • Engine:
    • Oil overfill.
    • Cam timing.
    • Cylinder compression.
    • Exhaust leaks before or near the HO2Ss.

I realize this is frustrating but hang in there, go thru one at at time. You got this @5.0 Hatch
 

hotcobra03

Well-Known Member
Established Member
Joined
Mar 11, 2007
Messages
7,274
Location
poteet,texas
How close to stock is this car.

These codes have vacuum
That appears to be cross of codes.

On my 03 vacuum hoses have been cause of o2 codes for me

For me the main pcv line ,,elbows soften and Crack.

This tiny hoses. I've found restrictions in.

I had taken off my vacuum harness and checked each line
With manually blowing and sucking thru ...

Throttle body to air inlet tube is another seal that's cracked on mine before it leaked and 1 time broke and held throttle open

Odd thing is your only seeing 1 bank. Po172

But got both on 1132/52

I'm interested in findings being
Po190 is a code I was having last time using my car .

For me I'm thinking fuel pump is getting tired .422k can't ask for much more .

I noticed I don't get problem till I go past half pedal .
My car will go into a limp mode ,run but like crap, with hand tuner while driving I can clear code and it's fine again till half pedal,,
 

Vinnie_B

"LIVE LIFE AT FULL THROTTLE"
Established Member
Premium Member
Joined
Jun 22, 2021
Messages
1,126
Location
Michigan
How close to stock is this car.

These codes have vacuum
That appears to be cross of codes.

On my 03 vacuum hoses have been cause of o2 codes for me

For me the main pcv line ,,elbows soften and Crack.

This tiny hoses. I've found restrictions in.

I had taken off my vacuum harness and checked each line
With manually blowing and sucking thru ...

Throttle body to air inlet tube is another seal that's cracked on mine before it leaked and 1 time broke and held throttle open

Odd thing is your only seeing 1 bank. Po172

But got both on 1132/52

I'm interested in findings being
Po190 is a code I was having last time using my car .

For me I'm thinking fuel pump is getting tired .422k can't ask for much more .

I noticed I don't get problem till I go past half pedal .
My car will go into a limp mode ,run but like crap, with hand tuner while driving I can clear code and it's fine again till half pedal,,
If you're are getting this same code P0190 @hotcobra03 . I would advise data logging your VREF voltage and FRP to see which is dropping out and start troubleshooting from there to isolate the issue. If you know of anybody who uses or has Ford IDS to scan your car it could be diagnosed within an hour.
 

hotcobra03

Well-Known Member
Established Member
Joined
Mar 11, 2007
Messages
7,274
Location
poteet,texas
I
If you're are getting this same code P0190 @hotcobra03 . I would advise data logging your VREF voltage and FRP to see which is dropping out and start troubleshooting from there to isolate the issue. If you know of anybody who uses or has Ford IDS to scan your car it could be diagnosed within an hour.
I haven't done much yet to diagnose mine.
I'm having another issue not code related but it's the ac.

Ccrm houses relay for ac issue I think I'm having. And fuel pump relay is in same area ,
Ac started to cut on/off
Than got to just touching throttle shut air off.
Ac WOT relay I'm thinking.

Wired ac clutch direct and ac works fine

I dealt with po148 cam sensor which ended up a stretch wire at connector 1 inch back. Assuming from pulling on wires to get plug off during working on drivers head.

I had used a multimeter on just engine harness section .
As you said on tools. It didn't take long to find wire break

Side note, our tundra. Always had a slipping transmission at your first stop every day,,sent to dealer,,refreshed update no help,

Went into limp mode 5 yrs later ,,got a stupid emissions code on engine. Forums all suggest to replace sensor. I cleaned it ,
Code cleared. But oddly. So did the slipping trans. Shifts like new now ,,
 

Vinnie_B

"LIVE LIFE AT FULL THROTTLE"
Established Member
Premium Member
Joined
Jun 22, 2021
Messages
1,126
Location
Michigan
There is a wire coming from Central Junction Box (CJB) F2-2 20 amp fuse. It is Hot in Start or Run that energizes the A/C clutch relay within the (Constant Control Relay Module (CCRM) which than goes to Powertrain Control Module (PCM) Focus on that being your issue @hotcobra03. I dont want to side track this thread but if youre stilling having a issue start a thread so we can help tackle your issue.
 

Users who are viewing this thread



Top