• Welcome to SVTPerformance!

Random Tapping after oil change with Amsoil filter and 5w-50.

Discussion in 'The Greasy Spoon' started by Booz, Oct 15, 2017.

  1. Booz

    Booz New Member

    Messages:
    9
    Joined:
    Oct 15, 2017
    Hey guys, I just recently got some Amsoil signature 5w-50 and the recommended Amsoil filter to go with it. After I got everything done, I ran up town about an hour later to get some errands out of the way, and as soon as I came to my first stop after the car had been completely warmed up I noticed it was making this random tapping sound; almost reminds me of someone smacking two ball bearings together, or those little firecrackers you throw at the ground that snap.

    Needless to say this is fairly concerning, so I figured it couldn't hurt to see what you guys think is going on. A friend of mine was saying if the sound doesn't go away, to try going back to the Motorcraft filter, and maybe try something thinner, such as a 0w-40 or 5w-30. He thought that the oil might not be getting hot enough, and the tapping was possibly stemming from that.

    The car is a 2014 Track Pack GT. I would appreciate any thoughts on the matter from you guys. I've been a long time lurker, but this issue made me sign up.
     
    Last edited: Oct 15, 2017
  2. CobraBob

    CobraBob Authorized Vendor Premium Member

    Messages:
    86,302
    Joined:
    Nov 17, 2002
    Location:
    Cheshire, CT
    The first thing I would try right away, since the tapping started right after you changed the filter, is 5w50 oil and a Motorcraft FL-500S filter (I'm pretty sure that's the right number).
     
    Last edited: Oct 16, 2017
  3. M91196

    M91196 Well-Known Member Established Member

    Messages:
    507
    Joined:
    Jan 1, 2015
    Location:
    New England
    Interesting, oil meets spec and TP calls for that weight. Filter should be high quality. If it was me I might spin on a new Ford filter and see, not likely but.....
    Then I would put the Motorcraft 5-50 in.
    FWIW that's what I've used with no issues on my TP
     
  4. PaxtonShelby

    PaxtonShelby 5.4 3-valve sucks big hairy donkey balls Established Member

    Messages:
    3,732
    Joined:
    Nov 16, 2010
    Location:
    Pittsburgh, PA
    Track Pack cars take 5w-50.
     
  5. me32

    me32 BEASTLY SHELBY GT500 TVS Premium Member Established Member

    Messages:
    10,517
    Joined:
    Sep 6, 2005
    Location:
    CA,NorCal
    How many miles on the car
     
  6. Booz

    Booz New Member

    Messages:
    9
    Joined:
    Oct 15, 2017
    Just bought the car in June, the car had 35k on it then, it has 42k now. It was quiet on whatever oil the dealer had used for it. They had the Motorcraft filter on it.

    Is there any reason to think that it could possibly go away with some time once the filter and oil break in a little? Because I put like 320 miles on it for work commutes each week, so I was going to give it until the end of this week, see if the noise persists, then go from there if needed.

    I appreciate the responses so far.
     
    Last edited: Oct 15, 2017
  7. Zemedici

    Zemedici #MeToo Established Member

    Messages:
    18,276
    Joined:
    Jan 7, 2013
    Location:
    Atlanta, GA
    Dumb question : How much oil did you put in it?
     
  8. PaxtonShelby

    PaxtonShelby 5.4 3-valve sucks big hairy donkey balls Established Member

    Messages:
    3,732
    Joined:
    Nov 16, 2010
    Location:
    Pittsburgh, PA
    Good question - should be 8.5 quarts.
     
  9. Booz

    Booz New Member

    Messages:
    9
    Joined:
    Oct 15, 2017
    I put 8 in, and checked the oil. Was right at the upper fill line as near as I could tell. New oil can be hard to see on the dip stick sometimes. Either way, it is within the brackets.
     
  10. me32

    me32 BEASTLY SHELBY GT500 TVS Premium Member Established Member

    Messages:
    10,517
    Joined:
    Sep 6, 2005
    Location:
    CA,NorCal
    Have you rechecked the oil level after driving the car on flat surface?
     
    Norton and 98 svt like this.
  11. CobraBob

    CobraBob Authorized Vendor Premium Member

    Messages:
    86,302
    Joined:
    Nov 17, 2002
    Location:
    Cheshire, CT
    Thanks for that correction. I just edited my post.
     
    PaxtonShelby likes this.
  12. Booz

    Booz New Member

    Messages:
    9
    Joined:
    Oct 15, 2017
    Yep, I drove the car to work and checked this morning when I got home to see if the level moved, and the dipstick was showing oil just about 2mm below the top fill line. So about half between the mid to top.

    If I was completely negligent and saw the oil was way down, I could see how oil level would be an issue, but I can't see how being a mm or two down from full would cause that noise. When I got to work the other day, I was listening to see if it was still making the noise, and it sounded like a typewriter at idle.

    If it doesn't quiet down come Thursday, the filter and oil is coming out, and the Motorcraft filter along with something else, oil wise is going in. I remember reading something awhile back on these forums when I was researching the car before I decided to buy, and there was a guy who had a similar issue and went to a 0-40 and that worked for him and a couple others who tried after him. If that is the case, then that would reinforce the thought that the oil is too thick for how the car is driven. Either that, or the motors are very picky about filter/oil combos. I have never ran into this on any of our other cars. Then again.. none of those were quad cam motors either... simple V6s which like 5-30. lol.
     
  13. 98 svt

    98 svt Well-Known Member Established Member

    Messages:
    14,938
    Joined:
    May 16, 2005
    Location:
    Nunya, MA
    You are sure it's not just injectors and it's paranoia since the oil change? The typewriter comment makes me think injectors.
     
  14. me32

    me32 BEASTLY SHELBY GT500 TVS Premium Member Established Member

    Messages:
    10,517
    Joined:
    Sep 6, 2005
    Location:
    CA,NorCal
    Is it possible for you to make a video of the noise you hear?
     
  15. Booz

    Booz New Member

    Messages:
    9
    Joined:
    Oct 15, 2017
    This is exactly the same as what I am hearing. Not my car, but what I am getting.


    Only happening when the car is warmed up and at idle. It's the slightly louder erratic snaps, or taps.
     
    Last edited: Oct 17, 2017
  16. PaxtonShelby

    PaxtonShelby 5.4 3-valve sucks big hairy donkey balls Established Member

    Messages:
    3,732
    Joined:
    Nov 16, 2010
    Location:
    Pittsburgh, PA
    My 2014 Track Pack has been on the noisy side since I did my first oil change. Not anywhere near as bad as in that video, but louder than it was previously. I have thought about trying the 5w20 that non TP GTs call for, as I don't run my car on a road course...just some WOT runs and drag strip a few times each year.
     
  17. Booz

    Booz New Member

    Messages:
    9
    Joined:
    Oct 15, 2017
    Well ya, as far as I know, the track pack gt's and the normal ones, motor wise are exactly the same internally. The only bolt on difference would be the oil cooler that the TP's have, but that's it to my knowledge.
     
  18. Booz

    Booz New Member

    Messages:
    9
    Joined:
    Oct 15, 2017
    Well, a small update.

    I went and got some Mobil 1 0-40 and put that in with the Motorcraft filter, and after driving to and from work, the tapping/snapping noise is already much better. I would imagine with a bit more time, it will probably stop all together.

    Update 2.
    Engine seems to be back to normal again. So at least I know from here out that it likes the Mobil 1 0-40 and the Motorcraft filter.
     
    Last edited: Oct 19, 2017
    FalkenXC likes this.
  19. 2FORDS

    2FORDS New Member Established Member

    Messages:
    17
    Joined:
    Sep 30, 2012
    Location:
    Oregon
    I would say that it was the filter. Amsoil 5w-50 is the only oil that meets the Ford oil spec in that weight,other than Motorcraft.
     
  20. 03Sssnake

    03Sssnake TK-421 Established Member Beer Money Bros.

    Messages:
    15,801
    Joined:
    Dec 9, 2002
    Location:
    not at my post...
    its not the filter and probably not the oil...my track pack 14 did this since new and occasionally does it right after changing the oil, would subside after a few hundred miles/completely go away (have 50K on the clock now). This sounds like the igniter tick/can of marbles, very erratic sounding. FWIW the TP cars do come with a 5-50 fill from the factory, but you don't have to use that. Normal GTs got 5-20 and there is nothing different interanally, you can really use anything in between. I have stuck to 5-30 Mobil 1 and Motorcraft 500, sometimes 820 filter. The 500S has lower bypass opening pressure, should be better for cold starts than the 820S.

    Friendly PSA, don't forget to change to that fall blend :D

    22688893_10203616608051423_5878820204900336562_n.jpg
     
    2FORDS likes this.

Share This Page